Validating credentials Error for building standand alone app

#1

After running exp build:ios -c and following the prompts I get the following error.

[exp] Error validating credentials. You may need to clear them (with '-c') and try again. [exp] Unable to validate credentials. Request ID 21b31390-eb4e-11e7-9218-8548f12bee92, message: Internal error occurred. Please try again in a few minutes or contact support.

#3

Still having issues with validating credentials but I have narrowed it down to an issue with my personal computer.
This is the output from my terminal

[exp] Making sure project is set up correctly...
[exp] Warning: Not using the Expo fork of react-native. See https://docs.expo.io/.
[exp] Your project looks good!
[exp] Checking if current build exists...
[exp] No currently active or previous builds for this project.
[exp] Removed existing credentials
? How would you like to upload your credentials?
 Expo handles all credentials, you can still provide overrides
We need your Apple ID/password to manage certificates and
provisioning profiles from your Apple Developer account.
Note: Expo does not keep your Apple ID or your Apple password.
? What's your Apple ID? stan@example.com
? Password? *********
[exp] Validating Credentials...
[exp] Error while gathering & validating credentials
[exp] undefined
[exp] Set EXPO_DEBUG=true in your env to view the stack trace.
1 Like
#4

can you try setting the EXPO_DEBUG env var to "true" and including the debug output generated by that?

#5

I’m seeing the same issue using version 47.2.4

When I run the command EXPO_DEBUG=true exp build:ios I get the following error:

[exp] Validating Credentials...
[exp] Error while gathering & validating credentials
[exp] [object Object]
[exp] undefined
[exp] undefined
#6

@noxee Hi, can you please try with the latest version 47.2.11

#7

Finally got an opportunity to try with DEBUG enabled

Updated to the latest Exp CLI and this is the output. Looks like I am validated as a user but it is looking for an app.

Now producing files for pushCert{ result: ‘failure’,
reason: ‘Unknown reason’,
rawDump: ‘Could not find app with bundle id ‘com.stanwilsonjr.wodstatus’’ }
[exp] Error while gathering & validating credentials
[exp] {}
[exp] Reason:Unknown reason, raw:“Could not find app with bundle id ‘com.stanwilsonjr.wodstatus’”
[exp] Error: Reason:Unknown reason, raw:"Could not find app with bundle id ‘com.stanwilsonjr.wodstatus’"
at IOSBuilder._throwIfFailureWithReasonDump (/Users/Edgar/universe/dev/exp/src/commands/build/IOSBuilder.js:354:13)
at IOSBuilder._callee5$ (/Users/Edgar/universe/dev/exp/src/commands/build/IOSBuilder.js:265:14)
at tryCatch (/Users/stanwilsonjr/.nvm/versions/node/v9.2.0/lib/node_modules/exp/node_modules/regenerator-runtime/runtime.js:62:40)
at Generator.invoke [as _invoke] (/Users/stanwilsonjr/.nvm/versions/node/v9.2.0/lib/node_modules/exp/node_modules/regenerator-runtime/runtime.js:296:22)
at Generator.prototype.(anonymous function) [as next] (/Users/stanwilsonjr/.nvm/versions/node/v9.2.0/lib/node_modules/exp/node_modules/regenerator-runtime/runtime.js:114:21)
at step (/Users/stanwilsonjr/.nvm/versions/node/v9.2.0/lib/node_modules/exp/node_modules/babel-runtime/helpers/asyncToGenerator.js:17:30)
at /Users/stanwilsonjr/.nvm/versions/node/v9.2.0/lib/node_modules/exp/node_modules/babel-runtime/helpers/asyncToGenerator.js:28:13
at
at process._tickCallback (internal/process/next_tick.js:188:7)

#8

Hi Stan, can you try again with exp 47.3.3 and if it doesn’t work, the output of it also with EXPO_DEBUG=true.

#9

Updated and i have the same issue… What is the process to create the bundle id?

Now producing files for pushCert{ result: 'failure',
reason: 'Unknown reason',
rawDump: 'Could not find app with bundle id \'com.stanwilsonjr.wodstatus\'' }
[exp] Error while gathering & validating credentials
[exp] {}
[exp] Reason:Unknown reason, raw:"Could not find app with bundle id 'com.stanwilsonjr.wodstatus'"
[exp] Error: Reason:Unknown reason, raw:"Could not find app with bundle id 'com.stanwilsonjr.wodstatus'"
    at IOSBuilder._throwIfFailureWithReasonDump (/Users/Edgar/universe/dev/exp/src/commands/build/IOSBuilder.js:354:13)
    at IOSBuilder._callee5$ (/Users/Edgar/universe/dev/exp/src/commands/build/IOSBuilder.js:265:14)
    at tryCatch (/Users/stanwilsonjr/.nvm/versions/node/v9.2.0/lib/node_modules/exp/node_modules/regenerator-runtime/runtime.js:62:40)
    at Generator.invoke [as _invoke] (/Users/stanwilsonjr/.nvm/versions/node/v9.2.0/lib/node_modules/exp/node_modules/regenerator-runtime/runtime.js:296:22)
    at Generator.prototype.(anonymous function) [as next] (/Users/stanwilsonjr/.nvm/versions/node/v9.2.0/lib/node_modules/exp/node_modules/regenerator-runtime/runtime.js:114:21)
    at step (/Users/stanwilsonjr/.nvm/versions/node/v9.2.0/lib/node_modules/exp/node_modules/babel-runtime/helpers/asyncToGenerator.js:17:30)
    at /Users/stanwilsonjr/.nvm/versions/node/v9.2.0/lib/node_modules/exp/node_modules/babel-runtime/helpers/asyncToGenerator.js:28:13
    at <anonymous>
    at process._tickCallback (internal/process/next_tick.js:188:7)
#10

@stanwilsonjr Sorry about that, I think I published a version incorrectly. Can you try again with the newest version. I also made it a bit more lenient about when to make the app (its part of the whole pipeline)

#11

@edgar Same issue with 47.3.5

#12

@stanwilsonjr Thanks for your patience, I have a reproducible test case now, so I am fixing it now. Will have a fix available soon, probably within the hour.

#13

Thanks man … may be able to hop back in this in the morning

#14

@stanwilsonjr sure thing, its 47.3.6 when you get a chance

#15

Things look good App ID was generated and I was able to generate an .ipa file. Thanks for your help and I will attempt to add to Test Flight.

1 Like
#16

I am new to this who ios deployment. I was impatient and i did exp build:ios -c

now when i run exp build:ios it asks me to my credentials. When i put them in i get this error

Any chance someone could walk me through the process to fix this. I dont know how to get the build id

Error while gathering & validating credentials
[exp] Reason:Multiple profiles found with the name
Please remove the duplicate profiles and try again. There were errors in the data supplied. Please correct and re-submit

#17

Upload was successful

1 Like
#18

Hi, please make new forum posts when you have your own, separate issues.

This means you already have a provisioning profile, please remove it from developer.apple.com and then try again with -c so that you start from a clean slate.

#19

Hey Guys, same issue here
EXPO_DEBUG=true exp build:ios

closed #20

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.