Warning! KeyboardShouldPersist

#1

I am receiving the below error Warning: ‘keyboardShouldPersistTaps={true}’ is depreciated us ‘Always’ instead, only solutions I have found involve updating react-native, not an option with Expo. Anyone solve this?

Deprecated Warning - no found solution
#2

I came across this problem when I used an older npm package that used the keyboardShouldPersistTaps={true} in one of it’s Scrollviews. I ended up forking the package and changing the param to keyboardShouldPersistTaps=“always”, then directing the package to my forked github version in my package.json file. It’s a bit of work for a small deprecation error, but it works!

1 Like