Websocket Android error sdk 28.0.1

#1

Hello,

I have a fully built detached app running on sdk 28.0.1 that works flawlessly in production for IOS but for android will sporadically receive the error:

Uncaught Error: WebSocketModule.close got 1 arguments, expected 3

and then crash unexpectedly.

I’ve searched react-native/issues on github and was suggested to use sdk 28.0.1 over 28.0.0 as the latest version contained a commit that fixed this bug, however the error is still persisting. Do we have any updates on this bug? Should I be posting this in the react-native/github issuses page? I would say the bug is a high priority as android is currently unusable.

#2

related upstream issue: https://github.com/facebook/react-native/issues/18696

#3

@notbrent The issue you linked is closed and the highest upvoted comment suggests to install react native ^0.55.3 to fix the problem. However, the sdk I’m currently using is expo sdk 28.0.1, which uses react native 0.55.4 and the bug is still presenting itself…

#4

If anyone one else is having this issue, I resolved it by rm -rf node_modules and then running exp publish afterwards. It seems that exp still had version 28.0.0 cached from the node_modules

1 Like
closed #5

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.