What OS versions are supported?

At the time of this writing, Expo managed projects support Android 5+ and iOS 10+.

In regards to using Unimodules in the bare workflow or vanilla react-native projects, the same versioning support applies. You may be able to get some packages working with older versions. However, this is not officially supported by Expo so the responsibility of implementing and maintaining them falls on you.

Cheers,
Adam