when i init expo i get error : npm ERR! Maximum call stack size exceeded


Unable to initialize git repo. `git` not in PATH.
Installing dependencies...
npm WARN deprecated deep-assign@3.0.0: Check out `lodash.merge` or `merge-options` instead.
npm WARN deprecated core-js@2.6.10: core-js@<3.0 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
npm WARN deprecated core-js@1.2.7: core-js@<3.0 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
npm WARN deprecated fsevents@1.2.9: One of your dependencies needs to upgrade to fsevents v2: 1) Proper nodejs v10+ support 2) No more fetching binaries from AWS, smaller package size
npm WARN tarball tarball data for metro@^0.51.0 (sha512-nM0dqn8LQlMjhChl2fzTUq2EWiUebZM7nkesD9vQe47W10bj/tbRLPiIIAxht6SRDbPd/hRA+t39PxLhPSKEKg==) seems to be corrupted. Trying one more time.
npm ERR! Maximum call stack size exceeded
npm WARN tar ENOENT: no such file or directory, open 'C:\Users\Amoory\Desktop\rn1\rn-app\node_modules\.staging\@react-native-community\cli-a792a931\build\commands\link\ios\addFileToProject.js'
npm WARN tar ENOENT: no such file or directory, open 'C:\Users\Amoory\Desktop\rn1\rn-app\node_modules\.staging\@react-native-community\cli-a792a931\build\commands\link\ios\addProjectToLibraries.js'
npm WARN tar ENOENT: no such file or directory, open 'C:\Users\Amoory\Desktop\rn1\rn-app\node_modules\.staging\@react-native-community\cli-a792a931\build\commands\link\ios\addSharedLibraries.js'

Hey @momoamoory,

Could you please run expo diagnostics and paste the log that is printed out here? Also, I would make sure you have git installed and that it is properly set in your PATH.

Cheers,
Adam