WSL not enabled on this machine when running "exp build:ios"

#1

After signing in with my apple ID and password i keep getting the following error.

Has anyone seen something like this before?

You can see the error in the linked picture and I have also pasted it into the post.

image

PS C:\Users\admin\Desktop\appname\appname> exp build:ios
[14:10:32] Making sure project is set up correctly…
[14:10:34] Your project looks good!
[14:10:35] Checking if current build exists…

[14:10:35] No currently active or previous builds for this project.
[14:10:35]
Does not seem like WSL enabled on this machine. Download from the Windows app
store a distribution of Linux, then in an admin powershell, please run:

Enable-WindowsOptionalFeature -Online -FeatureName Microsoft-Windows-Subsystem-Linux

and run the new Linux installation at least once

? How would you like to upload your credentials?
Expo handles all credentials, you can still provide overrides

We need your Apple ID/password to manage certificates and
provisioning profiles from your Apple Developer account.

Note: Expo does not keep your Apple ID or your Apple password.

? What’s your Apple ID? id
? Password? [hidden]
[14:11:56] Validating Credentials…
Error: spawn C:\Windows\system32\bash.exe ENOENT
at Process.ChildProcess._handle.onexit (internal/child_process.js:217:19)
at onErrorNT (internal/child_process.js:394:16)
at process._tickCallback (internal/process/next_tick.js:174:19)
PS C:\Users\admin\Desktop\appname\appname>

#2

I was able to progress through this error after finding the following post.

Here is the important content that helped from the post in case the link goes bad:

Please follow the warning & instructions printed to you by exp:

Does not seem like WSL enabled on this machine. Download from the Windows app store a distribution of Linux, then in an admin powershell, please run:

Enable-WindowsOptionalFeature -Online -FeatureName Microsoft-Windows-Subsystem-Linux

Basically, I went to the microsoft store and downloaded Ubuntu. I opened up the cmd window for it and created an Ubuntu account. After that i ran the above command and things seemed to work.

closed #3

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.