Xcode can't load published app

#1

I have run expo publish and gotten the URL for my offline app, and then run expo eject to ExpoKit. However, when I try to run the project in the xcworkspace in Xcode, I get the following error on the simulator:

Is there some step I’m missing? I have tried doing expo publish and then expo eject several times, and every time it tells me I still need to be serving my project through Expo CLI.

#2

Hi @lirvin!

Sorry about that :confused: could you try serving the app by running expo start and let me know if that lets you run through Xcode? Steps to follow can be found here

Thanks!
Charlie

#3

@charliecruzan Yes, that does work! However I want to be able to build the app on a simulator and on an iPhone without having to serve the app with expo start.

#4

Great! So for local development, you need to use the Expo CLI to serve your app. Once you build for release, that’s when your app will grab from the published url :+1:

#5

@charliecruzan Thanks for the response! Does this mean that I have to run “expo build:ios” no matter what? Or is there a way to do the build without that command? I am a student developing an app for a class, and do not have a paid Apple Developer account (and therefore cannot do expo build:ios with my free Apple Account).

#6

Unfortunately, that’s the only way to build your app binary for iOS. Without a paid Apple Developer account, it’s impossible.

If you don’t mind me asking, what made you decide to to eject?

#7

@charliecruzan I was trying to find a work around for paying $99 to Apple for a school project (evidently I was a little bit confused about what ejecting to ExpoKit did). Thank you for all the help!

Also, for future notice, it is a bit disappointing that having a developer account is the only way to do an IOS build! I really love the simplicity of Expo, but this will likely deter me from using it in the future. Just something to keep in mind!

#8

Yeah, ejecting to ExpoKit is usually just for people who have a project that needs a native module that Expo doesn’t currently support.

Sorry @lirvin, but it’s actually an Apple requirement that you have a paid Apple developer account to build standalone iOS apps :frowning: I agree with you that it would be so nice if that weren’t set in stone. But thanks for the feedback, it’s always good to hear what roadblocks/deterrents people run into

If you go with the managed workflow, you can always publish your app and access it through the Expo Client. That’s definitely the easiest way to share your app (without a paid developer account).