XCode Simulator Issue

#1

I am trying to open the expo app on the simulator, I have selected Xcode app from its preference settings.

Even I have already tried with following command but still am not able to open an app on simulator:

sudo xcode-select -s /Applications/Xcode.app

1 Like

#2

Hey @ankit.nectarbits,

What version of Xcode do you have installed and can you run expo diagnostics and paste the log that is printed out here?

Cheers,
Adam

0 Likes

#3

I’m using XCode 10.1 and the diagnostics log is as follow:

Expo CLI 2.10.1 environment info:
    System:
      OS: macOS High Sierra 10.13.6
      Shell: 3.2.57 - /bin/bash
    Binaries:
      Node: 11.9.0 - /usr/local/bin/node
      npm: 6.5.0 - /usr/local/bin/npm
      Watchman: 4.9.0 - /usr/local/bin/watchman
    IDEs:
      Xcode: 10.1/10B61 - /usr/bin/xcodebuild
    npmPackages:
      expo: ^32.0.0 => 32.0.4 
      react: 16.5.0 => 16.5.0 
      react-native: https://github.com/expo/react-native/archive/sdk-32.0.0.tar.gz => 0.57.1 
      react-navigation: ^3.2.1 => 3.2.1 
    npmGlobalPackages:
      expo-cli: 2.10.1
0 Likes

#4

In Simulator I face issue even if I run this command

sudo xcode-select -s /Applications/Xcode.app

But still I get this issue,

[12:56:38] Simulator not installed. Please visit https://developer.apple.com/xcode/download/ to download Xcode and the iOS simulator. If you already have the latest version of Xcode installed, you may have to run the command `sudo xcode-select -s /Applications/Xcode.app`.
Can't determine id of Simulator app; the Simulator is most likely not installed on this machine { Error: Command failed: osascript -e id of app "Simulator"
osascript: can't open default scripting component.

    at ChildProcess.exithandler (child_process.js:297:12)
    at ChildProcess.emit (events.js:197:13)
    at maybeClose (internal/child_process.js:978:16)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:265:5)
  killed: false,
  code: 1,
  signal: null,
  cmd: 'osascript -e id of app "Simulator"' }
0 Likes

closed #5

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

0 Likes