_xdl(...).ProjectUtils.readConfigJsonAsync is not a function

Expo CLI 3.4.1 environment info:
System:
OS: macOS 10.15
Shell: 3.2.57 - /bin/bash
Binaries:
Node: 12.13.1 - /usr/local/bin/node
npm: 6.12.1 - /usr/local/bin/npm
IDEs:
Android Studio: 3.5 AI-191.8026.42.35.5977832
Xcode: 11.1/11A1027 - /usr/bin/xcodebuild
npmPackages:
expo: ^35.0.1 => 35.0.1
react: 16.8.3 => 16.8.3
react-native: https://github.com/expo/react-native/archive/sdk-35.0.0.tar.gz => 0.59.8
react-navigation: ^3.13.0 => 3.13.0
npmGlobalPackages:
expo-cli: 3.4.1

Currently using Sublime Text

Updated to Expo CLI 3.8.0 last night, completely broke the entire dev environment. I have rolled back to CLI 3.4.1, but now every time I try to run expo start, or expo publish, or anything else, I get this error:

_xdl(…).ProjectUtils.readConfigJsonAsync is not a function
TypeError: _xdl(…).ProjectUtils.readConfigJsonAsync is not a function
at configureProjectAsync (/expo-cli@3.4.1/src/commands/start.js:188:43)
at action (/expo-cli@3.4.1/src/commands/start.js:58:34)
at /expo-cli@3.4.1/src/commands/start.js:230:16
at Command. (/expo-cli@3.4.1/src/exp.ts:81:7)

I went and did expo init on a new project, and same exact error.

Also ran these commends:

npm uni --no-save @expo/xdl
npm i --no-save @expo/xdl@56.8.0

Same error.

Hi buddy, just trying string in the next line and see if that works.

Regards,
Selen Smith