Eject sucsful but build failing for AppAuth on ios parse error

I did:

  1. expo eject from CLI with option to ExpoKit, it was succesful:
Epyons-iMac:The-Masjid-App-Mobile epyon$ expo eject
Your git working tree is clean
To revert the changes after this command completes, you can run the following:
  git clean --force && git reset --hard

? How would you like to eject your app?
  Read more: https://docs.expo.io/versions/latest/expokit/eject/ ExpoKit

> core-js@2.6.9 postinstall /Users/epyon/Documents/The-Masjid-App-Mobile/node_modules/fbjs-scripts/node_modules/core-js
> node scripts/postinstall || echo "ignore"


> core-js@2.6.9 postinstall /Users/epyon/Documents/The-Masjid-App-Mobile/node_modules/metro-babel-register/node_modules/core-js
> node scripts/postinstall || echo "ignore"


> core-js@2.6.9 postinstall /Users/epyon/Documents/The-Masjid-App-Mobile/node_modules/metro/node_modules/core-js
> node scripts/postinstall || echo "ignore"


> core-js@2.6.9 postinstall /Users/epyon/Documents/The-Masjid-App-Mobile/node_modules/react-native/node_modules/core-js
> node scripts/postinstall || echo "ignore"


> react-native-unimodules@0.6.0 postinstall /Users/epyon/Documents/The-Masjid-App-Mobile/node_modules/react-native-unimodules
> node ./scripts/postinstall.js


Successfully installed react-native-unimodules. This package contains core unimodules that are commonly depended on by other unimodules. You will need to configure your project before using other unimodules like expo-camera, expo-media-library and others.
See configuration guide:
  https://www.npmjs.com/package/react-native-unimodules/v/0.6.0

+ react-native-unimodules@0.6.0
removed 5 packages, updated 25 packages and audited 40182 packages in 4.041s
found 15 low severity vulnerabilities
  run `npm audit fix` to fix them, or `npm audit` for details
<CGColor 0x7fafcad02350> [<CGColorSpace 0x7fafcad02d00> (kCGColorSpaceDeviceRGB)] ( 0 0 0 1 )
<CGColor 0x7f832b6065f0> [<CGColorSpace 0x7f832b606fa0> (kCGColorSpaceDeviceRGB)] ( 0 0 0 1 )
<CGColor 0x7f918cf042d0> [<CGColorSpace 0x7f918cf04c80> (kCGColorSpaceDeviceRGB)] ( 0 0 0 1 )
<CGColor 0x7fb14ea00450> [<CGColorSpace 0x7fb14ea000e0> (kCGColorSpaceDeviceRGB)] ( 0 0 0 1 )
<CGColor 0x7f9222d0d520> [<CGColorSpace 0x7f9222d0ded0> (kCGColorSpaceDeviceRGB)] ( 0 0 0 1 )
<CGColor 0x7f97c2c0b9b0> [<CGColorSpace 0x7f97c2c0be90> (kCGColorSpaceDeviceRGB)] ( 0 0 0 1 )
<CGColor 0x7f826b4039b0> [<CGColorSpace 0x7f826b404360> (kCGColorSpaceDeviceRGB)] ( 0 0 0 1 )
<CGColor 0x7fb3c9e038a0> [<CGColorSpace 0x7fb3c9e04250> (kCGColorSpaceDeviceRGB)] ( 0 0 0 1 )
<CGColor 0x7fc75c906350> [<CGColorSpace 0x7fc75c906d00> (kCGColorSpaceDeviceRGB)] ( 0 0 0 1 )
<CGColor 0x7f91d0603740> [<CGColorSpace 0x7f91d06040f0> (kCGColorSpaceDeviceRGB)] ( 0 0 0 1 )
<CGColor 0x7fe552606120> [<CGColorSpace 0x7fe552606ad0> (kCGColorSpaceDeviceRGB)] ( 0 0 0 1 )
<CGColor 0x7fb3f440edf0> [<CGColorSpace 0x7fb3f440f7a0> (kCGColorSpaceDeviceRGB)] ( 0 0 0 1 )
<CGColor 0x7fa027605480> [<CGColorSpace 0x7fa027605e30> (kCGColorSpaceDeviceRGB)] ( 0 0 0 1 )
<CGColor 0x7fe1012030f0> [<CGColorSpace 0x7fe101203aa0> (kCGColorSpaceDeviceRGB)] ( 0 0 0 1 )
<CGColor 0x7fce16c021b0> [<CGColorSpace 0x7fce16c02b60> (kCGColorSpaceDeviceRGB)] ( 0 0 0 1 )
<CGColor 0x7fd5dd802c30> [<CGColorSpace 0x7fd5dd8035e0> (kCGColorSpaceDeviceRGB)] ( 0 0 0 1 )
<CGColor 0x7faa1cf0e650> [<CGColorSpace 0x7faa1cf05630> (kCGColorSpaceDeviceRGB)] ( 0 0 0 1 )
<CGColor 0x7fa166c00e20> [<CGColorSpace 0x7fa176d12be0> (kCGColorSpaceDeviceRGB)] ( 0 0 0 1 )
<CGColor 0x7f9020004b60> [<CGColorSpace 0x7f902000cc60> (kCGColorSpaceDeviceRGB)] ( 0 0 0 1 )
<CGColor 0x7fd59960e6f0> [<CGColorSpace 0x7fd599606980> (kCGColorSpaceDeviceRGB)] ( 0 0 0 1 )

> core-js@2.6.11 postinstall /Users/epyon/Documents/The-Masjid-App-Mobile/node_modules/fbjs-scripts/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@2.6.11 postinstall /Users/epyon/Documents/The-Masjid-App-Mobile/node_modules/metro-babel-register/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@2.6.11 postinstall /Users/epyon/Documents/The-Masjid-App-Mobile/node_modules/metro/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> core-js@2.6.11 postinstall /Users/epyon/Documents/The-Masjid-App-Mobile/node_modules/react-native/node_modules/core-js
> node -e "try{require('./postinstall')}catch(e){}"


> react-native-unimodules@0.6.0 postinstall /Users/epyon/Documents/The-Masjid-App-Mobile/node_modules/react-native-unimodules
> node ./scripts/postinstall.js


Successfully installed react-native-unimodules. This package contains core unimodules that are commonly depended on by other unimodules. You will need to configure your project before using other unimodules like expo-camera, expo-media-library and others.
See configuration guide:
  https://www.npmjs.com/package/react-native-unimodules/v/0.6.0

+ react-native-unimodules@0.6.0
+ expokit@35.0.4
+ react-native@0.59.8
added 4 packages from 1 contributor, updated 26 packages and audited 40185 packages in 11.953s
found 15 low severity vulnerabilities
  run `npm audit fix` to fix them, or `npm audit` for details
Ejected successfully!

I then did cd ios && pod install this was succesful:

Epyons-iMac:The-Masjid-App-Mobile epyon$ cd ios
Epyons-iMac:ios epyon$ pod install
Installing unimodules:
 expo-app-loader-provider@7.0.0 from ../node_modules/expo-app-loader-provider/ios
 expo-av@7.0.1 from ../node_modules/expo-av/ios
 expo-constants@7.0.0 from ../node_modules/expo-constants/ios
 expo-file-system@7.0.0 from ../node_modules/expo-file-system/ios
 expo-font@7.0.0 from ../node_modules/expo-font/ios
 expo-keep-awake@7.0.0 from ../node_modules/expo-keep-awake/ios
 expo-linear-gradient@7.0.0 from ../node_modules/expo-linear-gradient/ios
 expo-location@7.0.0 from ../node_modules/expo-location/ios
 expo-permissions@7.0.0 from ../node_modules/expo-permissions/ios
 expo-sqlite@7.0.0 from ../node_modules/expo-sqlite/ios
 expo-web-browser@7.0.1 from ../node_modules/expo-web-browser/ios
 unimodules-barcode-scanner-interface@4.0.0 from ../node_modules/unimodules-barcode-scanner-interface/ios
 unimodules-camera-interface@4.0.0 from ../node_modules/unimodules-camera-interface/ios
 unimodules-constants-interface@4.0.0 from ../node_modules/unimodules-constants-interface/ios
 unimodules-core@4.0.0 from ../node_modules/@unimodules/core/ios
 unimodules-face-detector-interface@4.0.0 from ../node_modules/unimodules-face-detector-interface/ios
 unimodules-file-system-interface@4.0.0 from ../node_modules/unimodules-file-system-interface/ios
 unimodules-font-interface@4.0.0 from ../node_modules/unimodules-font-interface/ios
 unimodules-image-loader-interface@4.0.0 from ../node_modules/unimodules-image-loader-interface/ios
 unimodules-permissions-interface@4.0.0 from ../node_modules/unimodules-permissions-interface/ios
 unimodules-react-native-adapter@4.0.0 from ../node_modules/@unimodules/react-native-adapter/ios
 unimodules-sensors-interface@4.0.0 from ../node_modules/unimodules-sensors-interface/ios
 unimodules-task-manager-interface@4.0.0 from ../node_modules/unimodules-task-manager-interface/ios

Analyzing dependencies
Fetching podspec for `DoubleConversion` from `../node_modules/react-native/third-party-podspecs/DoubleConversion.podspec`
Pre-downloading: `ExpoKit` from `http://github.com/expo/expo.git`, tag `ios/2.13.0`
Fetching podspec for `Folly` from `../node_modules/react-native/third-party-podspecs/Folly.podspec`
Fetching podspec for `glog` from `../node_modules/react-native/third-party-podspecs/glog.podspec`
Downloading dependencies
Installing Amplitude-iOS (4.9.3)
Installing Analytics (3.7.0)
Installing AppAuth (1.3.0)
Installing Branch (0.31.3)
Installing CocoaLumberjack (3.5.3)
Installing Crashlytics (3.13.4)
Installing DoubleConversion (1.1.6)
Installing EXAV (7.0.1)
Installing EXAppLoaderProvider (7.0.0)
Installing EXConstants (7.0.0)
Installing EXFileSystem (7.0.0)
Installing EXFont (7.0.0)
Installing EXKeepAwake (7.0.0)
Installing EXLinearGradient (7.0.0)
Installing EXLocation (7.0.0)
Installing EXPermissions (7.0.0)
Installing EXSQLite (7.0.0)
Installing EXWebBrowser (7.0.1)
Installing ExpoKit (35.0.0)
Installing FBAudienceNetwork (5.5.0)
Installing FBSDKCoreKit (5.6.0)
Installing FBSDKLoginKit (5.6.0)
Installing Fabric (1.10.2)
Installing Folly (2018.10.22.00)
Installing GTMAppAuth (1.0.0)
Installing GTMSessionFetcher (1.3.1)
Installing Google-Maps-iOS-Utils (2.1.0)
Installing GoogleMaps (3.7.0)
Installing GoogleSignIn (5.0.2)
Installing JKBigInteger2 (0.0.5)
Installing React (0.59.8)
Installing UMBarCodeScannerInterface (4.0.0)
Installing UMCameraInterface (4.0.0)
Installing UMConstantsInterface (4.0.0)
Installing UMCore (4.0.0)
Installing UMFaceDetectorInterface (4.0.0)
Installing UMFileSystemInterface (4.0.0)
Installing UMFontInterface (4.0.0)
Installing UMImageLoaderInterface (4.0.0)
Installing UMPermissionsInterface (4.0.0)
Installing UMReactNativeAdapter (4.0.0)
Installing UMSensorsInterface (4.0.0)
Installing UMTaskManagerInterface (4.0.0)
Installing boost-for-react-native (1.63.0)
Installing glog (0.3.5)
Installing lottie-ios (2.5.3)
Installing yoga (0.59.8.React)
Generating Pods project
Integrating client project
Pod installation complete! There are 41 dependencies from the Podfile and 47 total pods installed.

I then do expo start then I open ios/MY_APP.xcworkspace which opens it in xcode, then I hit the “Play” button but then it failes for parse error:

Parse Issue Group
/Users/epyon/Documents/The-Masjid-App-Mobile/ios/Pods/AppAuth/Source/iOS/OIDExternalUserAgentIOSCustomBrowser.h:38:1: Expected ','
/Users/epyon/Documents/The-Masjid-App-Mobile/ios/Pods/AppAuth/Source/iOS/OIDExternalUserAgentIOSCustomBrowser.m:19:9: In file included from /Users/epyon/Documents/The-Masjid-App-Mobile/ios/Pods/AppAuth/Source/iOS/OIDExternalUserAgentIOSCustomBrowser.m:19:
/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator12.4.sdk/usr/include/os/availability.h:93:171: Expanded from macro 'API_UNAVAILABLE'

Any ideas?