Error: connect ECONNREFUSED 127.0.0.1:19001


#1

Hello
i use macOS
Error when trying to run exp build:ios
could you tell me how to solve the problem?

Error code:
? Will you provide your own Distribution Certificate? Let Expo handle the process

? Will you provide your own Push Certificate? Let Expo handle the process
[13:51:05] Publishing to channel ‘default’…
[13:51:06] Warning: You are using npm version 5.6.0. There may be bugs in this version, use it at your own risk. We recommend version latest.
[13:51:08] Building iOS bundle
[13:51:08] Error: connect ECONNREFUSED 127.0.0.1:19001
[13:51:08] RequestError: Error: connect ECONNREFUSED 127.0.0.1:19001
at new RequestError (/usr/local/lib/node_modules/exp/node_modules/request-promise-core/lib/errors.js:14:15)
at Request.plumbing.callback (/usr/local/lib/node_modules/exp/node_modules/request-promise-core/lib/plumbing.js:87:29)
at Request.RP$callback [as _callback] (/usr/local/lib/node_modules/exp/node_modules/request-promise-core/lib/plumbing.js:46:31)
at self.callback (/usr/local/lib/node_modules/exp/node_modules/request/request.js:185:22)
at emitOne (events.js:116:13)
at Request.emit (events.js:211:7)
at Request.onRequestError (/usr/local/lib/node_modules/exp/node_modules/request/request.js:877:8)
at emitOne (events.js:116:13)
at ClientRequest.emit (events.js:211:7)
at Socket.socketErrorListener (_http_client.js:387:9)


#2

I just hit exactly the same error, any lead on what is causing this?


#3

I got it working by starting exp in another window, ‘exp start’


#4

try ‘exp start’ and then ‘exp:build:ios’
working very well!


#5

I am also experiencing this, but on Windows and trying to build an Android APK with exp build:android. I have created an issue on Github here.


#6

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.