Something went wrong

Here is blue screen --note address in browser. Was in original reply but only allowed to share 1 screen per reply or you would have gotten it in first post.

Robert

The app is available from expo’s github page https://github.com/expo/camerja which provides the link to demo at https://expo.io/@documentation/camerja.
I also see that you have made pull requests from this same repo. I can not see the demo because “Something went wrong …” and this is not my computer that published the app but was published by expo. I hope that this confirms that there is some problem that the team at expo needs to address because even the demo’s by expo are not visible to the public and/or developers.

Please note – apps work correctly using expo client on android phone as I am able to scan qr code from expo client which is not logged in or anonymous. The problem seems to exist when using browser based client as noted in pictures. I just confirmed cameraja and app from other account. Thanks for taking time to review problem and understand that I provide this feedback to help improve the product.

I would like to make a suggestion to improve the developer experience. As noted in the previous threads and several articles including slack through Google Search, the web browser (Tap to play provided by Appetize) does not always work which can be a little discerning, I would propose placing a toggle switch for the developer where he could enable/disable the web browser feature (Tap To Play – provided by Appetize) so that the expo client does not appear to be broken if the developer has not subscribed to Appetize. I feel that with that in place it causes harm to developer when potential client browses site because if they chose the tap to play and receive the blue screen – the normal response would be to look somewhere else. In that regard if I choose not to subscribe to Appetize I would appreciate it not being displayed on my account because it makes my code appear to be broken.

Thanks for your suggestion! Always great to hear back from the community :smile:

You shouldn’t need to have an appetize.io account to view or upload projects.

Just curious- are you able to use the simulator at https://snack.expo.io/ without any problems?

I hope that this confirms that there is some problem that the team at expo needs to address because even the demo’s by expo are not visible to the public and/or developers.

Sorry, but I’m still not seeing this behavior. Signed in/not signed in/incognito tab, your example app and Expo example apps, still nothing results in that behavior. You mentioned you tried it on a different machine, and it still didn’t work? Really difficult to try to pinpoint the cause since I’m not able to see this behavior on my end, and I haven’t seen it reported elsewhere either :confused:

I can use snacks in the simulator. I am not sure why it delivers that experience but the screenshots confirm a problem. I am using Imac and macbook pro, both are running MacOS Mojave version 10.14.5 and both are up to date from Apple updates for the respective machine. Both mac’s are setup for development for react with the macbook pro setup exclusively for react and react-native – expo included. In fact there is no other software on the macbook pro except visual studio code, github Desktop, xcode and android studio other than development tools for react etc…It is pretty lean in that respect as it is setup exclusively for development – nothing else.

For your information, I do have the same problem now

Expo CLI 3.0.4 environment info:
    System:
      OS: macOS 10.14.6
      Shell: 5.3 - /bin/zsh
    Binaries:
      Node: 10.16.0 - /usr/local/bin/node
      Yarn: 1.16.0 - /usr/local/bin/yarn
      npm: 6.9.0 - /usr/local/bin/npm
    IDEs:
      Android Studio: 3.4 AI-183.6156.11.34.5692245
      Xcode: 10.3/10G8 - /usr/bin/xcodebuild
    npmPackages:
      @bugsnag/expo: ^6.3.0 => 6.3.0
      expo: ^33.0.7 => 33.0.7
      react: 16.8.6 => 16.8.6
      react-native: https://github.com/expo/react-native/archive/sdk-33.0.0.tar.gz => 0.59.8
      react-navigation: ^3.11.1 => 3.11.1
    npmGlobalPackages:
      expo-cli: 3.0.4

Initial problem was (Unhandled JS Exception : Application main has not been register)
https://expo-developers.slack.com/archives/C04Q3JTSV/p1564137530319700

App i working fine in local dev mode, publish is OK with logged account

Published
Your URL is https://exp.host/@xxx/xxx-app?release-channel=staging

when I log with the account on Expo client or on web page (https://expo.io/@xxx/xxx-app), I can see the project.
but when I click on the icon, it displays “No experience found”

app.json

{
  "expo": {
    "name": "xxx",
    "slug": "xxx-app",
    "privacy": "unlisted",
    "sdkVersion": "33.0.0",
    "platforms": ["ios", "android", "web"],
    "version": "0.2.0",
    "orientation": "portrait",
    "icon": "./assets/images/expo.png",
    "splash": {
      "image": "./assets/images/5_creation_famille_app.png",
      "resizeMode": "contain",
      "backgroundColor": "#ffffff"
    },
    "updates": {
      "fallbackToCacheTimeout": 0
    },
    "assetBundlePatterns": ["**/*"],
    "ios": {
      "supportsTablet": true
    },
    "extra": {
      "bugsnag": {
        "apiKey": "-----"
      }
    },
    "hooks": {
      "postPublish": [
        {
          "file": "@bugsnag/expo/hooks/post-publish.js",
          "config": {}
        }
      ]
    },
    "packagerOpts": {
      "sourceExts": ["js", "json", "ts", "tsx", "jsx"]
    }
  }
}

I tryed also “open in browser link” from the project page, logged in my the account, I have this message :

I’ve created a brand new account same message !

Hey @lc3t35, I think this is a different issue since I see the same error screen for your project (in the other case, I was able to view it from the browser successfully, which was the weird part).

In your case, could you try running it in production mode locally? use the command expo start --no-dev --minify which will simulate the production environment

If that works, then I would also try publishing to the default channel and seeing if you’re able to view via the browser after that (since it looks like you’re using release channels)

Hi @charliecruzan; I was able to find the source of my problems :

  1. Unhandled JS Exception : Application main has not been register
    The app was crashing right at startup due an incorrect usage of manifest.debuggerHost.split(…) at staging : it is undefined when not in __DEV__ mode, so it crashed when published in channel staging.
    I was able to find the issue using bugsnag.notify

  2. No experience found at exp://exp.host/@undefined
    When you remove the project (default channel) with the web access, and publish again in staging channel, the app listed in the profile is not the staging one but still the default one.
    If you use the link provided, with ?release-channel=staging at the end, open it on your mobile, it goes to the correct version of the app.
    Then the app is displayed in Projects in the “recently opened app”, with “staging” displayed on the right side

Imho, Expo client should be modified to update and display in the Profile page (not only in the Projects page) the app in the according release-channels.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.