After expo upgrade, appear expo splash in my app

Please provide the following:

  1. SDK Version: 39
  2. Platforms(Android/iOS/web/all): android (didn’t check ios)

Replace this section with as much relevant information as possible and any relevant code along with your question.

Hello.
After upgrading the expo, a strange splash page is appearing on my app.

https://imgur.com/a/Wa5qlnq

When I run the app, I see the expanded expo logo before I see the splash page I created, but I have no idea what the problem is.

Before, there was no problem and it was used well.

This is app.json tree

expo : {
  ios : {
    splash : {
      image : ""
    }
  }
  android : {
    splash : {
      image : ""
    }
  }
}

What should I do?

1 Like

I’m experiencing the same thing, but after upgrading to SDK40.

I only have the root “splash” configuration, not the ones below ios and android. I tried adding it there, but same thing.

why do you provide a splash screen configuration with an empty image string and no background color? what are you trying to accomplish?

@peterfares - can you share your app.json config and related files? and a screenshot of what you see?

Just figured it out. Apparently I was still on expo-cli 3.27 and upgrading to expo-cli 4.0 fixed the issue.

The issue I saw was just like OP, showed the expo logo as splash screen on standalone builds. expo app didn’t show any splash screen (just background color).

interesting, your cli version shouldn’t have any impact on this. all of the code around applying splash screen to standalone builds runs on expo servers

Does the CLI choose which files to upload? Because the CLI upgrade fixed it. It fixed the standalone build and running it in the expo app.

it doesn’t. i think there was an unrelated change in your app that fixed it, but could be mistaken. would have to have a reproducible example to understand more deeply

Well I don’t know what to say. I spent 2+ hours trying to figure it out and as soon as I upgraded the expo-cli it was fixed and it made no changes to my git repo.

if you can share your app.json and splash files so i can try to reproduce it would be helpful.

Here is my app.json
Splash is a simple single PNG file

{
  "expo": {
    "name": "evee",
    "slug": "evee-app",
    "privacy": "public",
    "platforms": [
      "ios",
      "android"
    ],
    "version": "0.7.43",
    "orientation": "portrait",
    "icon": "./assets/icon.png",
    "splash": {
      "image": "./assets/splash.png",
      "resizeMode": "cover",
      "backgroundColor": "#000000"
    },
    "updates": {
      "checkAutomatically": "ON_ERROR_RECOVERY",
      "fallbackToCacheTimeout": 0
    },
    "assetBundlePatterns": [
      "**/*"
    ],
    "scheme": "eveeapp",
    "backgroundColor": "#121519",
    "userInterfaceStyle": "dark",
    "ios": {
      "bundleIdentifier": "app.evee.mobile",
      "supportsTablet": false,
      "buildNumber": "15",
      "googleServicesFile": "./GoogleService-Info.plist",
      "config": {
        "googleMapsApiKey": "..."
      }
    },
    "android": {
      "package": "app.evee.mobile",
      "versionCode": 15,
      "googleServicesFile": "./google-services.json",
      "config": {
        "googleMaps": {
          "apiKey": "..."
        }
      },
      "permissions": []
    },
    "androidStatusBar": {
      "translucent": true,
      "barStyle": "light-content",
      "backgroundColor": "#17264e66"
    },
    "androidNavigationBar": {
      "barStyle": "light-content",
      "backgroundColor": "#12161A"
    },
    "web": {
      "config": {
        "firebase": {
          "apiKey": "...",
          "authDomain": "...",
          "databaseURL": "...",
          "projectId": "...",
          "storageBucket": "...",
          "messagingSenderId": "...",
          "appId": "...",
          "measurementId": "..."
        }
      }
    },
    "extra": {
      "sentryNativeDSN": "..."
    },
    "packagerOpts": {
      "projectRoots": "",
      "config": "rn-cli.config.js"
    },
    "hooks": {
      "postPublish": [
        {
          "file": "sentry-expo/upload-sourcemaps",
          "config": {
            "organization": "evee-services-inc",
            "project": "evee-react-native",
            "authToken": "..."
          }
        }
      ]
    }
  }
}

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.