Amplitude Version Deprecation


#1

Hey y’all, I received an email from Amplitude that on January 1st, 2019 any Amplitude SDK’s older that 4.1.1 will be deprecated and events from those will no longer be received. It looks like Expo is still using an older one, I think, but I cannot find in the docs which version. In my Amplitude events it shows an old version. I was wondering when the plans are to update the Expo Amplitude SDK version so that next year I won’t start losing events.

Email below:

In April, we informed our customer-base about an issue where, under a specific set of circumstances that were tied to the local browsing environment, use of a version of the JavaScript SDK older than 4.1.1 may result in some data contamination across Amplitude customer organization boundaries. The original bulletin is included below for your reference.

Once we discovered and verified this issue, we added a control in JS SDK 4.1.1 that has shown itself to be effective in mitigating this scenario, even as Amplitude cannot control it directly.

Many of our customers have updated the Amplitude JS SDK version in their applications. Unfortunately, some customers have yet to do so. As a result, we have concluded that it is appropriate at this time to deprecate all older versions of the JS SDK that lack this mitigation. As such, Amplitude will deprecate all versions of the JS SDK older than 4.1.1 on January 31, 2019, and beginning February 1, 2019, Amplitude will no longer support those versions of the JS SDK. This means that on February 1, 2019 we will stop collecting data from JS SDKs older than 4.1.1.


closed #2

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.