Android App Bundle rejected for lack of 64-bit support

I’m running into the 64-bit requirement error after building an android bundle using sdk-34.

I’m successfully building an app bundle using expo build:android --no-publish --type app-bundle and successfully uploading to the play store release track. I’m unable to publish, however, with the error:

This release is not compliant with the Google Play 64-bit requirement
The following APKs or App Bundles are available to 64-bit devices, but they only have 32-bit native code: .
Include 64-bit and 32-bit native code in your app. Use the Android App Bundle publishing format to automatically ensure that each device architecture receives only the native code it needs. This avoids increasing the overall size of your app

My expo diagnostics:

  Expo CLI 3.0.9 environment info:
    System:
      OS: macOS 10.14.6
      Shell: 3.2.57 - /bin/bash
    Binaries:
      Node: 8.14.0 - /usr/local/bin/node
      npm: 6.10.3 - /usr/local/bin/npm
    IDEs:
      Android Studio: 3.3 AI-182.5107.16.33.5264788
      Xcode: 10.3/10G8 - /usr/bin/xcodebuild
    npmPackages:
      @storybook/react-native: ^4.1.14 => 4.1.18
      expo: ^33.0.0 => 33.0.7
      react: 16.8.3 => 16.8.3
      react-native: https://github.com/expo/react-native/archive/sdk-33.0.0.tar.gz => 0.59.8
      react-navigation: ^2.9.3 => 2.18.3
    npmGlobalPackages:
      expo-cli: 3.0.9

Is there any additional steps I should be doing to enable 64-bit support in my app bundle?

You mentioned that you are using sdk-34 but diagnostic show that you have sdk 33 npm packages installed.
Please post your app.json and package.json
Unzip aab generated by build command and check if directories lib/arm64-v8a, lib/armeabi-v7a, lib/x86, lib/x86_64 contains the same *.so files(are there any missing).

Sorry, I don’t know what’s wrong. I just wanted to point out that you say you’re using SDK v34, but your diagnostics show SDK v33.

Thanks for looking!

This ended up being because of the --no-publish. The bundle picked up a previously published release which wasn’t compatible with sdk33/34, and was therefore not 64-bit ready.

Ran the standard expo build:android --type app-bundle and it solved my problem.

1 Like