Android backward compatibility

#1

Hi,

So I managed to build a standalone app for use on Android but my client has Android 4.2.2 which is not supported by Expo. Is there any way that I can build my react app for use on Android 4.2.2?

It is not possible to upgrade the OS to a later version unfortunately and there are a lot of tablets so it’s quite expensive to replace the devices.

Thanks!

#2

I think if you detach to ExpoKit, you may be able to support an earlier version of Android than 4.4, but I’m not positive.

cc @jesse

#3

That’s what I tried to do but because ExpoKit and some other packages required a minimum SDK version of 19 I couldn’t make it work. So I ended up re-creating a new React Native application with the standard method and copying over the code, then I changed the minimum version in the manifest file, but it was quite a hassle to set the signing certificates for Android as it was my first time. I’d rather use Expo :wink: but I couldn’t do otherwise this time, ultimately it worked though.

#4

I think the problem here isn’t Expo not supporting Android version below 4.4, it’s your client still having an Android 4.2.2 (which is 5 years old now). You probably should recommend him to upgrade or change his device for something more recent.

#5

Yes, the problem is that upgrading Android to a later version is not always possible, not through the normal flow that is, as the device provider stops supporting the device and provide software updates.

Another problem is that in order to replace some 30 tablets with newer ones could be quite expensive and the client might not always like the idea or be able to do that kind of investment for the time being.

#6

You got your problem just here :stuck_out_tongue:
I understand that the client might not want to invest in new devices, but clearly the problem isn’t on your side.

Good luck!