Android Build Error on Expo 26 Upgrade

#1

After getting everything upgraded the prescribed way, I’m getting a build error in the emulator:

From what I can tell, the DetachBuildConstants.java file is not getting updated when running exp start but not sure why…

#2

Hey @michael.neeley,

Can you upgrade to expo-cli and see if that helps? https://github.com/expo/expo-cli

exp has been replaced for quite some time now and expo-cli is its replacement.

Cheers,
Adam

#3

Ok I’m using the new CLI, same error. How can I debug?