Android standalone build failing due to ':expo-camera'


#1

My android build is failing due to following reason:
I haven’t used this package in my project, but the link given below does not seem to work. Anyone else facing this issue?

[stderr] FAILURE: Build failed with an exception.
[stderr] * What went wrong:
[stderr] A problem occurred configuring project ':expo-camera'.
[stderr] > Could not resolve all files for configuration ':expo-camera:classpath'.
[stderr]    > Could not find lint-gradle-api.jar (com.android.tools.lint:lint-gradle-api:26.1.2).
[stderr]      Searched in the following locations:
[stderr]          https://jcenter.bintray.com/com/android/tools/lint/lint-gradle-api/26.1.2/lint-gradle-api-26.1.2.jar
[stderr] * Try:
[stderr] Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
[stderr] * Get more help at https://help.gradle.org
[stderr] BUILD FAILED in 18s
Error: Process exited with non-zero code: 1
    at ChildProcess.child.on (/app/node_modules/@expo/spawn-async/build/spawnAsync.js:39:21)
    at emitTwo (events.js:126:13)
    at ChildProcess.emit (events.js:214:7)
    at maybeClose (internal/child_process.js:915:16)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:209:5)


#2

I have the same issue but yesterday I compiled the same code and it works…
I think that the problem is in expo turtle.

WARNING: Configuration 'compile' is obsolete and has been replaced with 'implementation' and 'api'.
It will be removed at the end of 2018. For more information see: http://d.android.com/r/tools/update-dependency-configurations.html
[stderr] FAILURE: Build failed with an exception.
[stderr] * What went wrong:
[stderr] A problem occurred configuring project ':expo-camera'.
[stderr] > Could not resolve all files for configuration ':expo-camera:classpath'.
[stderr]    > 
[stderr] Could not find lint-gradle-api.jar (com.android.tools.lint:lint-gradle-api:26.1.2).
[stderr]      Searched in the following locations:
[stderr]          https://jcenter.bintray.com/com/android/tools/lint/lint-gradle-api/26.1.2/lint-gradle-api-26.1.2.jar
[stderr] * Try:
[stderr] Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
[stderr] * Get more help at https://help.gradle.org
[stderr] BUILD FAILED in 15s
Error: Process exited with non-zero code: 1
    at ChildProcess.child.on (/app/node_modules/@expo/spawn-async/build/spawnAsync.js:39:21)
    at emitTwo (events.js:126:13)
    at ChildProcess.emit (events.js:214:7)
    at maybeClose (internal/child_process.js:915:16)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:209:5)

#3

Yeah, same for me. Tried after sometime and it worked!


#4

Same here. Also sometimes build goes through, but mostly fails.


#5

Facing this issue again. Had built an apk successfully, then failed again after sometime.


#6

https://jcenter.bintray.com/com/android/tools/lint/lint-gradle-api/26.1.2/lint-gradle-api-26.1.2.jar
This link seems to be creating an issue. Says resource not available.


#7

Hey guys, I think this commit should solve the issue, it has just been deployed to the builders, so I hope builds won’t be failing anymore. :slightly_smiling_face: Have a nice day!


closed #8

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.