App runs in development but in production

#1

My app works fine in a local dev environment both in iOS simulator and an Android device, yet it does not work in production. It just hangs at the starting time. I cannot provide any errors logs since expo app does not produce ones. Here is a link to the app on my expo account https://expo.io/@sakhmedbayev/chitaempisanie.

What can I do to debug production app? Just FYI, my app is using push notifications.

{
  "expo": {
    "name": "Some name",
    "icon": "../../app.png",
    "version": "1.0.0",
    "slug": "somename",

    "sdkVersion": "28.0.0",
    "ios": {
      "bundleIdentifier": "org.myapp.myapp"
    },
    "android": {
      "package": "org.myapp.myapp",
      "permissions": ["VIBRATE", "com.google.android.c2dm.permission.RECEIVE"]
    }
  }
}

some outputs from my package.json:

"dependencies": {
    "@expo/vector-icons": "^6.2.1",
    "antd-mobile": "^2.1.2",
    "apollo-cache-inmemory": "^1.1.12",
    "apollo-client": "^2.2.2",
    "apollo-fetch": "^0.7.0",
    "apollo-fetch-upload": "^1.2.0",
    "apollo-link": "^1.0.6",
    "apollo-link-batch-http": "1.0.5",
    "apollo-link-state": "^0.4.1",
    "apollo-link-ws": "^1.0.3",
    "apollo-logger": "0.1.1",
    "axios": "^0.18.0",
    "expo": "^28.0.0",
    "filesize": "^3.5.11",
    "graphql": "^0.12.3",
    "graphql-iso-date": "^3.3.0",
    "graphql-tag": "^2.6.0",
    "immutability-helper": "^2.6.2",
    "lodash": "^4.17.4",
    "minilog": "^3.1.0",
    "native-base": "^2.3.5",
    "prop-types": "^15.6.0",
    "react": "16.3.1",
    "react-apollo": "^2.1.4",
    "react-debounce-input": "^3.1.0",
    "react-native": "^0.55.3",
    "react-navigation": "^2.5.5",
    "react-redux": "^5.0.6",
    "react-stripe-elements": "^1.2.1",
    "redux": "^3.7.2",
    "subscriptions-transport-ws": "^0.9.4"
  },
  "devDependencies": {
    "apollo-utilities": "^1.0.3",
    "babel-cli": "^6.26.0",
    "babel-core": "^6.26.0",
    "babel-eslint": "^8.0.3",
    "babel-plugin-styled-components": "^1.3.0",
    "babel-plugin-transform-class-properties": "^6.24.1",
    "babel-plugin-transform-decorators-legacy": "^1.3.4",
    "babel-plugin-transform-react-remove-prop-types": "^0.4.12",
    "babel-plugin-transform-runtime": "^6.23.0",
    "babel-polyfill": "^6.26.0",
    "babel-preset-env": "^1.6.1",
    "babel-preset-flow": "^6.23.0",
    "babel-preset-minify": "^0.2.0",
    "babel-preset-react": "^6.24.1",
    "babel-preset-react-native": "^4.0.0",
    "babel-preset-stage-0": "^6.24.1",
    "babel-register": "^6.26.0",
    "caporal": "^0.9.0",
    "chai": "^4.1.2",
    "chai-http": "^3.0.0",
    "compression": "^1.7.1",
    "connect": "^3.6.5",
    "cross-env": "^5.1.1",
    "css-loader": "^0.28.7",
    "enzyme": "^3.2.0",
    "enzyme-adapter-react-16": "^1.1.0",
    "eslint": "^4.13.1",
    "eslint-config-airbnb": "^16.1.0",
    "eslint-import-resolver-webpack": "^0.8.3",
    "eslint-plugin-flowtype": "^2.40.1",
    "eslint-plugin-import": "^2.8.0",
    "eslint-plugin-json": "^1.2.0",
    "eslint-plugin-jsx-a11y": "6.0.3",
    "eslint-plugin-mocha": "^4.11.0",
    "eslint-plugin-prettier": "^2.4.0",
    "eslint-plugin-react": "^7.5.1",
    "exp": "^55.0.4",
    "extract-text-webpack-plugin": "^3.0.2",
    "file-loader": "^1.1.6",
    "flow-bin": "^0.62.0",
    "freeport-async": "^1.1.1",
    "haul": "1.0.0-beta.11",
    "heroku-babel-loader": "^7.1.2",
    "html-webpack-plugin": "^2.30.1",
    "http-proxy-middleware": "^0.17.4",
    "ignore-loader": "^0.1.2",
    "image-size": "^0.6.2",
    "ip": "^1.1.5",
    "isomorphic-style-loader": "^4.0.0",
    "jsdom": "^11.5.1",
    "lerna": "^2.5.1",
    "less": "^2.7.3",
    "less-loader": "^4.0.5",
    "mkdirp": "^0.5.1",
    "mocha": "^4.0.1",
    "mocha-steps": "^1.1.0",
    "mocha-webpack": "^0.7.0",
    "node-sass": "^4.7.2",
    "openurl": "^1.1.1",
    "persistgraphql-webpack-plugin": "^0.4.4",
    "prettier": "^1.9.2",
    "qrcode-terminal": "^0.11.0",
    "raw-loader": "^0.5.1",
    "react-addons-test-utils": "^16.0.0-alpha.3",
    "react-test-renderer": "^16.2.0",
    "request": "^2.83.0",
    "resolve-url-loader": "^2.2.1",
    "rimraf": "^2.6.2",
    "sass-loader": "^6.0.6",
    "source-list-map": "^2.0.0",
    "style-loader": "^0.19.1",
    "url-loader": "^0.6.2",
    "wait-on": "^2.0.2",
    "webpack": "^3.10.0",
    "webpack-dev-middleware": "^2.0.1",
    "webpack-dev-server": "^2.9.7",
    "webpack-hot-middleware": "^2.21.0",
    "webpack-manifest-plugin": "^1.3.2",
    "webpack-merge": "^4.1.1",
    "webpack-node-externals": "^1.6.0",
    "webpack-sources": "^1.1.0",
    "webpack-virtual-modules": "^0.1.8",
    "ws": "^5.1.1",
    "xdl": "^49.2.0"
  },
#2

If u are using remote updates, look this post

#3

Thank you @victorwads for the response! Can you please tell me what are “remote updates”?

#4

@sakhmedbayev remoteUpdates is a feature that expo provides to your user can update the app js bundles without update the app it self. When you use exp publish.

https://docs.expo.io/versions/latest/sdk/updates

1 Like
closed #5

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.