Branch event with blank bundle record


#1

Hi,

We have been using Branch with Expo 28.0.0 successfully for a few weeks. We recently upgraded to Expo 29 and noticed that Branch events contain ‘blank’ bundle records instead of the data conained in the deep link that opened (or installed) the app. The app is an iOS app in TestFlight and the deep link successfully takes us to TestFlight first that opens or installs the app just like in the last few weeks, however the deep link bundle data passed in is now empty.
We have not changed the Branch configuration and the way the links are created. The only change we are aware of is that we have upgraded to Expo 29.

The JSON bundle object we receive is:
{
“error”:null,
“uri”:null,
“params”:
{
“+is_first_session”:false,
“+clicked_branch_link”:false,
“cached_initial_event”:true
}
}

Code that subscribes to and handles branch events:
this._unsubscribeDeepLinking = Branch.subscribe(async (bundle) => await this._deepLinking(bundle));

async _deepLinking(bundle) {

(this function does get called with the above bundle object)

I wonder if anyone has come across this recently. I am not sure whether it is an Expo 29 or Branch issue. I have also contacted Branch and waiting for their answer.

Any hints would be appreciated.


#2

This problem was eventually solved by deleting node_modules and reinstalling the packages.
Deep linking works fine now.


#3

Glad you got it resolved, @claimlogik!


#4

Thanks Adam.

Nandor


closed #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.