Build IOS 22/05/2018

#1

17:29:20 [exp] Validating Credentials…
17:29:25 [exp] Error while gathering & validating credentials
17:29:25 [exp] Reason:Unknown reason, raw:"{“authType”=>“hsa2”}\ndslang=US-EN; Domain=apple.com; Path=/; Secure; HttpOnly, site=USA; Domain=apple.com; Path=/; Secure; HttpOnly, acn01=nGoWIeU/MOGnMWVpBI36J5dF5qVxQMIp4vKIDBkAEI34qBg8Sw==; Max-Age=31536000; Expires=Wed, 22-May-2019 10:29:24 GMT; Domain=apple.com; Path=/; Secure; HttpOnly"
17:29:25 [exp] Set EXPO_DEBUG=true in your env to view the stack trace.

2 Likes
#2

Same problem, but not two days ago.

20:31:26 [exp] Validating Credentials...
20:31:31 [exp] Error while gathering & validating credentials
20:31:31 [exp] Reason:Unknown reason, raw:"{\"authType\"=>\"hsa2\"}\naa=DCD76BBA7BEB765688EB39214D3F83CB; Domain=idmsa.apple.com; Path=/; Secure; HttpOnly, dslang=US-EN; Domain=apple.com; Path=/; Secure; HttpOnly, site=USA; Domain=apple.com; Path=/; Secure; HttpOnly, acn01=OlmWnRvHvMTHlANESXtnIEAMfzpPVuxyiUcAEKXcFsnDjQ==; Max-Age=31536000; Expires=Wed, 22-May-2019 12:31:31 GMT; Domain=apple.com; Path=/; Secure; HttpOnly"
20:31:31 [exp] Set EXPO_DEBUG=true in your env to view the stack trace.
1 Like
#3

I successed but when
generating IPA…
[stderr] [05:24:30] ‘ios:build-and-sign-ipa’ errored after 16 s
[stderr] [05:24:30] Error: Process exited with non-zero code: 1
[stderr] at ChildProcess.child.on (/usr/local/turtle-agent/tools-public/node_modules/@expo/spawn-async/build/spawnAsync.js:39:21)
[stderr] at emitTwo (events.js:125:13)
[stderr] at ChildProcess.emit (events.js:213:7)
[stderr] at maybeClose (internal/child_process.js:927:16)
[stderr] at Socket.stream.socket.on (internal/child_process.js:348:11)
[stderr] at emitOne (events.js:115:13)
[stderr] at Socket.emit (events.js:210:7)
[stderr] at Pipe._handle.close [as _onclose] (net.js:545:12)
unable to build and sign IPA

#4

Same question 能联系你吗 QQ:289670502

#5

Hi everyone! We just rolled out some changes which should output more helpful errors when builds fail. If you run them again and could let us know whether it’s helpful or if not, could post them here with the build ID, that’d be great. Thanks for bearing with us!

#6

Just connect to https://appleid.apple.com/ or http://itunesconnect.apple.com and accept the privacy update.

Taken from: https://stackoverflow.com/questions/50458774/expo-buildios-fails-with-error-while-gathering-validating-credentials

#7


I had build , but facing same

#8

It looks like you can’t use iOS development certificates.

#9

I’m build other app , so same

#10

Same issue.

#11

Has everyone logged into their apple developer account and accepted the new privacy update?

closed #12

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.