build:ios fails


#1

Hi,

My build failed and I am not getting any error I can work with.
build: 011ed3b8-42a5-40fc-b369-8e545c54e5e0

Could someone please guide me here?

Thanks!


#2

Hi! Here are the logs from the build:

DEBUG [2018-07-03 20:21:41.80]: /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/detect_values.rb:78:in `[]'
1
ERROR [2018-07-03 20:21:41.80]: Couldn't automatically detect the provisioning profile mapping
1
ERROR [2018-07-03 20:21:41.80]: Since Xcode 9 you need to provide an explicit mapping of what
1
ERROR [2018-07-03 20:21:41.80]: no implicit conversion of Symbol into Integer
1
ERROR [2018-07-03 20:21:41.80]: provisioning profile to use for each target of your app
1
ERROR [2018-07-03 20:22:15.36]: Exit status: 70
1
ERROR [2018-07-03 20:22:15.43]: Before submitting an issue on GitHub, please follow the guide above and make
1
ERROR [2018-07-03 20:22:15.43]: It's hard to tell what's causing the error, so we wrote some guides on how
1
ERROR [2018-07-03 20:22:15.43]: Looks like fastlane ran into a build/archive error with your project
1
ERROR [2018-07-03 20:22:15.43]: sure your project is set up correctly.
1
ERROR [2018-07-03 20:22:15.43]: to troubleshoot build and signing issues: https://docs.fastlane.tools/codesigning/getting-started/
1
ERROR [2018-07-03 20:22:15.44]: Make sure to inspect the output above, as usually you'll find more error information there
1
ERROR [2018-07-03 20:22:15.44]: fastlane uses `xcodebuild` commands to generate your binary, you can see the
1
ERROR [2018-07-03 20:22:15.44]: the full commands printed out in yellow in the above log.

I’m not sure exactly what went wrong based on the logs. Can you give us more information about how you generated the credential? Did you let Expo generate them for you?


closed #3

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.