Cannot register my ios device on expo client

Please provide the following:

  1. SDK Version: 38.0.0
  2. Platforms(iOS): all

I am trying to install an adhoc build for my app on an ios device. I have followed the instructions in the below link:
https://docs.expo.io/guides/adhoc-builds/?redirected#registering-multiple-ios-devices

I have received this message:
Open the following link on your iOS device (or scan the QR code) and follow the instructions to install the development profile:

https://expo.io/udid/cmaWRkvqGELSadePuwwFDN

Please note that you can only register one iOS device per request.
After you register your device, we’ll start building your client, and you’ll receive an email when it’s ready to install.

The issue now is that when I scan the QR code and receive the profile on my phone, I see that some certificates are not verified as per the below screenshots:

I still tried to install the profile, however it redirects me this page:

Client Build Status

:warning: Waiting for user to register their device for development

REQUEST ID

bcdf3ecb-b751-4982-b527-33458ca21a70

DESCRIPTION

Please check your email for directions to register your device UDID.

However I didn’t receive any email.
I am not sure why api.expo.dev certificate is expired (on 23 August 2020). Is this the major cause of the issue or there is something else wrong?

SDK: 37
Expo CLI: 3.26.2

We are experiencing the same thing. We’re in the process of upgrading from an older SDK 36 -> SDK 37 (incrementally making our way to SDK 38).

On an iPad that has successfully had an SDK 36 compatible custom client, I removed the old Expo Client (custom) and went through the same process using the new CLI, but it appears the profile won’t fully install on my device.

Hi folks we are working together with @tsaidavid, here is the log error I have when trying to run expo client:ios, here is the output that I see:

git:(master) EXPO_DEBUG=true expo client:ios
┌──────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────┐
│                                                                                                                                          │
│   There is a new version of expo-cli available (3.26.2).                                                                                 │
│   You are currently using expo-cli 3.11.0                                                                                                │
│   Install expo-cli globally using the package manager of your choice; for example: `npm install -g expo-cli` to get the latest version   │
│                                                                                                                                          │
└──────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────┘
✔ Found custom configuration for the Expo client at /Users/<redacted>/app.json
Please enter your Apple Developer Program account credentials. These credentials are needed to manage
certificates, keys and provisioning profiles in your Apple Developer account.
The password is only used to authenticate with Apple and never stored.
? Apple ID: <redacted>
? Password (for <redacted>): [hidden]
Trying to authenticate with Apple Developer Portal...
Authentication with Apple Developer Portal failed!
Reason: Unknown reason, raw: "SSL_connect returned=1 errno=0 state=error: certificate verify failed"
Error: Reason: Unknown reason, raw: "SSL_connect returned=1 errno=0 state=error: certificate verify failed"
    at runAction (/expo-cli@3.11.0/src/appleApi/fastlane.ts:28:17)
    at processTicksAndRejections (internal/process/task_queues.js:97:5)
    at Object.authenticate (/expo-cli@3.11.0/src/appleApi/authenticate.ts:46:40)
    at /expo-cli@3.11.0/src/commands/client/index.js:72:24
    at Command.<anonymous> (/expo-cli@3.11.0/src/exp.ts:81:7)
➜  git:(master)

UPD: I got to fix it by updating CLI version to the latest

And now I see this


When I am trying to watch running build

Having the same issue with Expo v.37 &iPhone 6 with iOS 12.4.8.

My steps are:

  1. Run expo client:ios & choose let Expo manage for all the options

  2. Scan the QRcode the showed up with the message:

Open the following link on your iOS device (or scan the QR code) and follow the instructions to install the development profile:

https://expo.io/udid/bFknfHnec1MATqkR5yzKdv
  1. Get redirect to the expo.io webpage showing:
Register your UDID
  1. Press Register & download the profile.

  2. Nav to settings > Profile downloaded > see the Expo profile with the green verified check > press install

  3. Get redirect to expo.io webpage showing:

Client Build Status
⚠️ Waiting for user to register their device for development

Has anyone figured it out? :frowning:

I had the same issue and was able to make it work. These are the steps I took, I am not sure which one was the fix, so I am listing them all:

  1. Updated expo-cli (npm install -g expo-cli)
  2. Removed the Download Profile that I installed previously (when it failed at “waiting for user to register…”)
  3. expo client:io again. In the last question (Would you like to register a new device to use the Expo client with?) i selected NO. This time, it didn’t asked to Download/Install a profile, it just started building the client (after some time waiting for a free serve).