Can't build after upgrading to SDK 35

Please provide the following:

  1. SDK Version: 35.00
  2. Platforms: iOS

Expo diagnostic inputs:

 Expo CLI 3.28.5 environment info:
    System:
      OS: macOS 10.15.6
      Shell: 5.7.1 - /bin/zsh
    Binaries:
      Node: 10.13.0 - ~/.nvm/versions/node/v10.13.0/bin/node
      Yarn: 1.21.1 - /usr/local/bin/yarn
      npm: 6.4.1 - ~/.nvm/versions/node/v10.13.0/bin/npm
    Managers:
      CocoaPods: 1.9.3 - /usr/local/bin/pod
    SDKs:
      iOS SDK:
        Platforms: iOS 14.2, DriverKit 20.0, macOS 11.0, tvOS 14.2, watchOS 7.1
    IDEs:
      Android Studio: 3.5 AI-191.8026.42.35.6010548
      Xcode: 12.2/12B45b - /usr/bin/xcodebuild
    npmPackages:
      expo: ^35.0.0 => 35.0.1 
      react: 16.8.3 => 16.8.3 
      react-dom: 16.8.3 => 16.8.3 
      react-native: https://github.com/expo/react-native/archive/sdk-35.0.0.tar.gz => 0.59.8 
      react-native-web: ^0.11.7 => 0.11.7 
      react-navigation: ^4.0.0 => 4.4.3 
    npmGlobalPackages:
      expo-cli: 3.28.5
    Expo Workflow: managed

I upgraded from SDK 34 by running expo upgrade, after upgrading the immediate output was "The following packages were not updated. You should check the READMEs for those repositories to determine what version is compatible with your new set of packages. The list is around 30 packages: @react-native-firebase/app, @react-native-firebase/messaging, …etc. Run pod install in your iOS directory and then re-build your native projects to compile the updated dependencies

So I ran cd ios && pod install
Pod install kept failing with the following message:
Unable to find a specification for React-Coredepended upon byreact-native-safe-area-context`

You have either:

  • out-of-date source repos which you can update with pod repo update or with pod install --repo-update.
  • mistyped the name or version.
  • not added the source repo that hosts the Podspec to your Podfile.
I tried `npm install react-native-safe-area-context`, I see that react-native-safe-area-context is in my pod file as follows:
pod 'react-native-safe-area-context', :path => '../node_modules/react-native-safe-area-context'

I've done both pod repo update and pod install --repo-udpate, but it keeps failing with the same error.
Any idea on how to get around any of this?

Hi

One thing you might try is create a new app like:

expo init --template=expo-template-blank@sdk-35 new-app

Then install all your dependencies, eject, etc. At that point you could try copying all of your code across, or else compare the new and old app config files and ios directory contents to figure out what’s wrong.

Ok, I’ll go ahead and do this and post my findings here. Ultimately I want to get my app to the point where it uses SDK 39 but I’m afraid that updating from 34 -> 39 could require so much changes from my end that I’d have no clue why things are failing.

Yes, I would definitely go one SDK at a time rather than just jump straight to the latest SDK version.