[!] CocoaPods could not find compatible versions for pod "Crashlytics":

Please provide the following:

  1. SDK Version: 36
  2. Platforms(Android/iOS/web/all): iOS

I’m using React Native Firebase and I followed the configuration for Crashlytics according to the documentation, but during the pod installation there is an error related to mismatch of versions for the package “@react-native-firebase/crashlytics”: “^6.3.4”.

[!] CocoaPods could not find compatible versions for pod "Crashlytics":
  In Podfile:
    ExpoKit/Core (from `http://github.com/expo/expo.git`, tag `ios/2.14.4`) was resolved to 36.0.0, which depends on
      Crashlytics (~> 3.13.4)

    RNFBCrashlytics (from `../node_modules/@react-native-firebase/crashlytics`) was resolved to 6.3.4, which depends on
      Crashlytics (~> 3.14.0)

Expo uses ‘Crashlytics’, ‘~> 3.13.4’ ExpoKit.podspec but the dependency has a higher version 3.14.0 RNFBCrashlytics.podspec

I’m already tried some suggestions like updating the pods:
pod repo update or pod install --repo-update

I tried to set an specific version for Crashlytics in the Pod file:

pod ‘RNFBCrashlytics’, :path => ‘…/node_modules/@react-native-firebase/crashlytics’

pod ‘Crashlytics’, ‘~> 3.14.0’

But this also throws an error:

Specs satisfying the Crashlytics (~> 3.14.0), Crashlytics (~> 3.13.4) dependency were found, but they required a higher minimum deployment target.

Can someone please help me with this issue?

I have the same issue… Why Expo depends on Crashlytics…?

I have the same problem. Have you find any solution for this?

Nope, I disabled Crashlytics in the meantime, I will look for another tool like Sentry. I also opened an issue in Github, you can try that solution https://github.com/expo/expo/issues/7256

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.