Could not connect Android emulator after detach


#1

I want to test building standalone apps using ExpoKit, and just did these steps :

1. npm install exp --global
2. exp init my-new-project
3. cd my-new-project
4. exp detach
5. react-native run-android

But I got errors below:

Starting JS server...
Building and installing the app on the device (cd android && gradlew.bat installDebug)...
Could not install the app on the device, read the error above for details.
Make sure you have an Android emulator running or a device connected and have
set up your Android development environment.

I did not modifiy any code lines and my computer is indeed running an android emulator, becase I can run any projects using [react-native init XXX], and command [adb device] show this:

List of devices attached
192.168.15.101:5555     device

Please help me. Here is package.json:

{
  "main": "node_modules/expo/AppEntry.js",
  "private": true,
  "dependencies": {
    "expo": "^25.0.0",
    "react": "16.2.0",
    "react-native": "https://github.com/expo/react-native/archive/sdk-25.0.0.tar.gz"
  }
}

#2

Hi! Please make sure you’re following all of the Developing With ExpoKit instructions. Looks like you’re using react-native run-android rather than using XDE or exp, one of which is required to communicate with the Expo libraries included with ExpoKit.


#3

I use XDE to create a new project, but it has the same issue. @dikaiosune

I find that there is no file gradlew.bat in dir /android , is this normal ?

My node version is v6.11.4.

Someone can help ?


closed #4

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.