Could not receive latest API key from App Store Connect, this might be a server issue

I am trying to build iOS app on a newly created project with expo. The problem is that even though I am providing correct credentials of my Apple Developer account, I am getting the following message.

Here are my expo diagnostics.

Any help?