Defaut language error ENOENT app.json

#1

Hello,

I trying changing the default language to French for my app by following this guide: https://docs.expo.io/versions/latest/guides/app-stores.html#localizing-system-dialogs-on-ios

But I get this error:

Even though “./languages/french.json” exists
image

Here’s what I added in app.json
image

Could someone please help?

@ben

Thanks :raised_hands:

0 Likes

#2

Hey @botmane,

What version of exp are you using? Also, I would double check to make sure the spelling of directories is correct and the paths are correct.

Cheers,

Adam

0 Likes

#3

Hi,

I’m using Expo 28 SDK, and verified multiple times that the path is correct:

0 Likes

#4

Hey, when I said exp version I meant the version of the exp CLI not what SDK version you are running! Can you run exp --version and let me know what it says?

0 Likes

#5

Sorry…:sweat_smile:

I was using exp v50.0 and I just updated exp CLI to v56.0 but still have the same error.

Thank you in advance for your help

0 Likes

#6

@botmane No worries! Alright, I’m going to ask internally about this.

0 Likes

#7

Hey @botmane, what directory are you running the command from? exp won’t resolve relative paths so they will be looked up relative to the current working directory.

0 Likes

closed #8

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

0 Likes