EAS Build failed after changing app name

Hi folks, I recently changed the app name in the app.json and now my eas build is failing for iOS.

What’s weird is expo build:ios (archive) works… but eas build fails with the following error:

› Compiling gem » noop-file.swift
› Compiling gem » main.m
› Compiling gem » bitclout_vers.c
› Compiling gem » AppDelegate.m
› Linking   gem » bitclout
› Copying ios/gem/Supporting/Expo.plist ➜ Expo.plist
› Compiling gem » SplashScreen.storyboard
› Compiling gem » LaunchScreen.xib
› Preparing gem » Info.plist
› Executing gem » 'Bundle React Native code and images'
    the transform cache was reset.

❌  error: File /Users/expo/Library/Developer/Xcode/DerivedData/gem-dqjsbbgaxeotckdjhvlzdlqmozov/Build/Intermediates.noindex/ArchiveIntermediates/gem/BuildProductsPath/Release-iphoneos/bitclout.app/main.jsbundle does not exist. This must be a bug with

› Generating debug gem » 'bitclout.app.dSYM'
⚠️  Pods/boost-for-react-native: iOS@8.0 deployment version mismatch, expected >= 9.0 <= 14.4.99
▸ ** ARCHIVE FAILED **
▸ The following build commands failed:
▸ 	PhaseScriptExecution Bundle\ React\ Native\ code\ and\ images /Users/expo/Library/Developer/Xcode/DerivedData/gem-dqjsbbgaxeotckdjhvlzdlqmozov/Build/Intermediates.noindex/ArchiveIntermediates/gem/IntermediateBuildFilesPath/gem.build/Release-iphoneos/gem.build/Script-00DD1BFF1BD5951E006B06BC.sh
▸ (1 failure)
** ARCHIVE FAILED **
The following build commands failed:
	PhaseScriptExecution Bundle\ React\ Native\ code\ and\ images /Users/expo/Library/Developer/Xcode/DerivedData/gem-dqjsbbgaxeotckdjhvlzdlqmozov/Build/Intermediates.noindex/ArchiveIntermediates/gem/IntermediateBuildFilesPath/gem.build/Release-iphoneos/gem.build/Script-00DD1BFF1BD5951E006B06BC.sh
(1 failure)
Exit status: 65

Here is my app.json and my eas.json:

{
  "expo": {
    "name": "gem",
    "slug": "gem",
    "version": "1.0.0",
    "orientation": "portrait",
    "icon": "./assets/images/icon.png",
    "scheme": "myapp",
    "userInterfaceStyle": "automatic",
    "splash": {
      "image": "./assets/images/splash.png",
      "resizeMode": "contain",
      "backgroundColor": "#ffffff"
    },
    "updates": {
      "fallbackToCacheTimeout": 30000
    },
    "assetBundlePatterns": [
      "**/*"
    ],
    "ios": {
      "supportsTablet": true,
      "bundleIdentifier": "com.gem.bitclout",
      "buildNumber": "1.0.0"
    },
    "android": {
      "package": "com.gem.bitclout",
      "versionCode": 1,
      "adaptiveIcon": {
        "foregroundImage": "./assets/images/adaptive-icon.png",
        "backgroundColor": "#ffffff"
      }
    },
    "web": {
      "favicon": "./assets/images/favicon.png"
    }
  }
}

{
  "builds": {
    "android": {
      "release": {
        "workflow": "managed"
      }
    },
    "ios": {
      "release": {
        "workflow": "managed"
      }
    }
  }
}

Adding my package.json as well:

{
  "main": "node_modules/expo/AppEntry.js",
  "scripts": {
    "start": "expo start",
    "android": "expo start --android",
    "ios": "expo start --ios",
    "web": "expo start --web",
    "eject": "expo eject",
    "test": "jest --watchAll",
    "lint": "eslint '*/**/*.{js,ts,tsx}' --quiet --fix",
    "prettier": "prettier --config .prettierrc '**/*.ts' --write"
  },
  "jest": {
    "preset": "jest-expo"
  },
  "dependencies": {
    "@expo/vector-icons": "^12.0.0",
    "@react-native-community/masked-view": "0.1.10",
    "@react-navigation/bottom-tabs": "5.11.2",
    "@react-navigation/native": "~5.8.10",
    "@react-navigation/stack": "~5.12.8",
    "@types/lodash": "^4.14.170",
    "@types/react": "~16.9.35",
    "@types/react-native": "~0.63.2",
    "@types/uuid": "^8.3.0",
    "@typescript-eslint/eslint-plugin": "^4.26.0",
    "@typescript-eslint/parser": "^4.26.0",
    "axios": "^0.21.1",
    "eslint": "^7.27.0",
    "expo": "~41.0.1",
    "expo-asset": "~8.3.1",
    "expo-constants": "~10.1.3",
    "expo-font": "~9.1.0",
    "expo-image-picker": "~10.1.4",
    "expo-linking": "~2.2.3",
    "expo-media-library": "~12.0.2",
    "expo-secure-store": "~10.1.0",
    "expo-splash-screen": "~0.10.2",
    "expo-status-bar": "~1.0.4",
    "expo-web-browser": "~9.1.0",
    "lodash": "^4.17.21",
    "react": "16.13.1",
    "react-dom": "16.13.1",
    "react-native": "https://github.com/expo/react-native/archive/sdk-41.0.0.tar.gz",
    "react-native-elements": "^3.4.1",
    "react-native-gesture-handler": "~1.10.2",
    "react-native-reanimated": "~2.1.0",
    "react-native-safe-area-context": "3.2.0",
    "react-native-screens": "~3.0.0",
    "react-native-web": "~0.13.12",
    "react-native-webview": "^11.6.2",
    "uuid": "^3.4.0"
  },
  "devDependencies": {
    "@babel/core": "^7.9.0",
    "eslint-config-prettier": "^8.3.0",
    "eslint-plugin-prettier": "^3.4.0",
    "eslint-plugin-react": "^7.24.0",
    "jest-expo": "~41.0.0",
    "prettier": "^2.3.0",
    "typescript": "~4.0.0"
  },
  "private": true
}

Actual errors are in xcode logs, you have some invalid imports there

e[0m e[90m  9 |e[39m e[36mimporte[39m e[33mPostEntrye[39m e[36mfrome[39m e[32m'../../api/PostEntry'e[39me[33m;e[39me[0m
e[0m e[90m 10 |e[39m e[36mimporte[39m e[33mProfileEntrye[39m e[36mfrome[39m e[32m'../../api/ProfileEntry'e[39me[33m;e[39me[0m
e[0m e[90m 11 |e[39m e[36mimporte[39m { useIdentity } e[36mfrome[39m e[32m'../Identity'e[39me[33m;e[39me[0m
    at ModuleResolver.resolveDependency (/Users/expo/workingdir/build/node_modules/metro/src/node-haste/DependencyGraph/ModuleResolution.js:168:15)
    at DependencyGraph.resolveDependency (/Users/expo/workingdir/build/node_modules/metro/src/node-haste/DependencyGraph.js:353:43)
    at Object.resolve (/Users/expo/workingdir/build/node_modules/metro/src/lib/transformHelpers.js:271:42)
    at resolve (/Users/expo/workingdir/build/node_modules/metro/src/DeltaBundler/traverseDependencies.js:571:33)
    at /Users/expo/workingdir/build/node_modules/metro/src/DeltaBundler/traverseDependencies.js:587:26
    at Array.reduce (<anonymous>)
    at resolveDependencies (/Users/expo/workingdir/build/node_modules/metro/src/DeltaBundler/traverseDependencies.js:586:33)
    at /Users/expo/workingdir/build/node_modules/metro/src/DeltaBundler/traverseDependencies.js:275:33
    at Generator.next (<anonymous>)
    at asyncGeneratorStep (/Users/expo/workingdir/build/node_modules/metro/src/DeltaBundler/traverseDependencies.js:87:24)
+ [[ false != true ]]

1 Like