Error: EMFILE: too many open files

Running ‘expo start’ suddenly gives this error:

 Expo  Press ? to show a list of all available commands.
Logs for your project will appear below. Press Ctrl+C to exit.
2020-04-07 14:32 node[56066] (FSEvents.framework) FSEventStreamStart: register_with_server: ERROR: f2d_register_rpc() => (null) (-22)

2020-04-07 14:32 node[56066] (FSEvents.framework) FSEventStreamStart: register_with_server: ERROR: f2d_register_rpc() => (null) (-22)

2020-04-07 14:32 node[56066] (FSEvents.framework) FSEventStreamStart: register_with_server: ERROR: f2d_register_rpc() => (null) (-22)

events.js:298
      throw er; // Unhandled 'error' event
      ^

Error: EMFILE: too many open files, watch
    at FSEvent.FSWatcher._handle.onchange (internal/fs/watchers.js:129:28)
Emitted 'error' event on NodeWatcher instance at:
    at NodeWatcher.checkedEmitError (/Users/xxxx/xxxx/xxx/xxxx/xxxx/node_modules/sane/src/node_watcher.js:143:12)
    at FSWatcher.emit (events.js:321:20)
    at FSEvent.FSWatcher._handle.onchange (internal/fs/watchers.js:135:12) {
  errno: -24,
  syscall: 'watch',
  code: 'EMFILE',
  filename: null
}

I changed nothing in the code, just ran expo start after not touching the project for 2 months. last time I used the exact code to build and ship to the stores with no problem.

diagnostic:

Expo CLI 3.17.18 environment info:
    System:
      OS: macOS Mojave 10.14.6
      Shell: 3.2.57 - /bin/bash
    Binaries:
      Node: 13.8.0 - /usr/local/bin/node
      Yarn: 1.21.1 - /usr/local/bin/yarn
      npm: 6.13.7 - /usr/local/bin/npm
    IDEs:
      Android Studio: 3.2 AI-181.5540.7.32.5056338
      Xcode: 11.3.1/11C504 - /usr/bin/xcodebuild
    npmPackages:
      expo: ~36.0.0 => 36.0.2 
      react: ~16.9.0 => 16.9.0 
      react-native: https://github.com/expo/react-native/archive/sdk-36.0.0.tar.gz => 0.61.4 
      react-navigation: ^4.0.10 => 4.0.10 
    npmGlobalPackages:
      expo-cli: 3.17.18

Any ideas anyone?

Reinstalling watchman solves it, although I was on the latest version. Keeping this here for reference:
brew reinstall watchman

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.