Error in Expo SDK 18 - You cannot render into anything but a top root


#1

Hi guys, I have found a weird issue, I upgraded my projects to SDK 18 ( RN 45 ) and now, when my apps start they crash.
I have found a way ti make them run. If I turn on remote debugging and refresh an app, the issues goes away, if I turn it off and refresh the app, the issue is back. I can see this message in chrome dev tools You cannot render into anything but a top root. It looks there is an existing issue in RN (https://github.com/facebook/react-native/issues/14717)

BTW: only tested in Android


#2

We haven’t been able to reproduce this issue. Can you try to reproduce it using https://snack.expo.io/ and post a link?


#3

It’s hard to reproduce but I’m not the only one having this issue, I’ll make a new project and publish the link here. I’m not sure it is reproducible on snack.