I want to use react-native-background-geolocation library in my ExpoKit project version 34.0.0. however, I’m getting an error related to CocoaLumberjack version conflict after adding this library.
Here is my error, it seems that ExpoKit is using old version of CocoaLumberjack. What can I do about it? Can I somehow upgrade version of CocoaLumberjack? will it affect my project?
here is an error:
CocoaPods could not find compatible versions for pod “CocoaLumberjack”:
In snapshot (Podfile.lock):
CocoaLumberjack (= 3.2.1, ~> 3.2.1)
CocoaLumberjack (= 3.5.3)
ExpoKit/Core (from `http://github.com/expo/expo.git`, tag `ios/2.12.1`) was resolved to 34.0.0, which depends on CocoaLumberjack (~> 3.2.1) RNBackgroundGeolocation (from `../node_modules/react-native-background-geolocation`) was resolved to 3.2.0, which depends on CocoaLumberjack (~> 3.5.1)
It seems like you’ve changed the constraints of dependency
CocoaLumberjack inside your development pod
You should run
pod update CocoaLumberjack to apply changes you’ve made.