Error while building iOS standalone app


#1

I keep getting an error while trying to create an stand alone app for iOS.

This is my build id: b91d3883-d280-4688-b697-77ba9df09efb

And my app.json looks like this:

{
  "expo": {
    "sdkVersion": "15.0.0",
    "icon": "./images/taxiApp.png",
    "slug": "RutappTaxi-Driver",
	"version":"1.0.0",
	"buildNumber":"1",
	"loading": {
	"icon": "./images/taxiApp.png",
	"hideExponentText": false
	},
    "ios": {
      "bundleIdentifier": "com.rutapp.taxirider",
		"version":"1.0.0",
		"icon": "./images/taxiApp.png",
		"buildNumber":"1",
		"splash":{
			"image":"./images/launchImages/splashscreen.png",
			"backgroundColor":"#FF0000"
		},
		"config":{"googleMapsApiKey":"*******************"}
    },
    "loading": {
      "hideExponentText": true,
      "icon": "./images/loading.png",
      "backgroundImage": "./images/launchImages/splashscreen.png"
    },
    "orientation": "portrait",
    "primaryColor": "#cccccc",
    "facebookScheme": "fb1919559661598816",
    "packagerOpts": {
      "assetExts": ["ttf"]
    }
  }
}

Is there any way to view a log of what’s going on? I only get: [exp] iOS: There was an error with this build.


#2

hi- sorry for the delay. here is the error i saw in the logs.
we’re working on a way to surface these directly to users. sorry that isn’t done yet.

[!] Apple provided the following error info:
	An App ID with Identifier 'io.nativebase.market.geekyants.taxiapp' is not available. Please enter a different string.
stdout:[14:58:26]: Get started using a Gemfile for fastlane https://docs.fastlane.tools/getting-started/ios/setup/#use-a-gemfile

+----------------+----------------------------------------+
|               Summary for produce 2.56.0                |
+----------------+----------------------------------------+
| username       | carlos@rutapp.mx                       |
| team_id        | 8R8S87UMR9                             |
| app_identifier | io.nativebase.market.geekyants.taxiapp |
| skip_itc       | true                                   |
| app_name       | StrapTaxiApp-Rider                     |
| app_version    | 3.0.1                                  |
| sku            | 1510873108                             |
| platform       | ios                                    |
| language       | English                                |
| skip_devcenter | false                                  |
+----------------+----------------------------------------+

[14:58:31]: Creating new app 'StrapTaxiApp-Rider' on the Apple Dev Center

Looking for related GitHub issues on fastlane/fastlane...

Found no similar issues. To create a new issue, please visit:
https://github.com/fastlane/fastlane/issues/new
Run `fastlane env` to append the fastlane environment to your issue

I think you might need to change the app identifier (“io.nativebase.market.geekyants.taxiapp”)