Existing react native project trying to run with expo and facing errors


#1

Hi, Im trying to up and run, someone elses react-native project but i’m super new on react-native, i just start from 2 days ago.Im facing with those errors at the below you can see, my step for create and implement on expo.

I create a new react-native app following code,

$ npm install -g expo-cli
$ expo init flamingio
$ cd flamingio/
$ npm start

after this i just copy the folders of existing react-native folder on my flamingio folder;

Here is the existing react-native package.json:

{
  "name": "flamingioMobile",
  "version": "0.0.1",
  "private": true,
  "scripts": {
    "start": "node node_modules/react-native/local-cli/cli.js start",
    "test": "jest"
  },
  "dependencies": {
    "npm": "^5.10.0",
    "react": "16.3.1",
    "react-native": "0.55.4",
    "react-native-onesignal": "^3.2.4",
    "react-native-wkwebview-reborn": "^1.21.0"
  },
  "devDependencies": {
    "babel-jest": "22.4.3",
    "babel-preset-react-native": "4.0.0",
    "jest": "22.4.3",
    "react-test-renderer": "^16.4.1"
  },
  "jest": {
    "preset": "react-native"
  }
}

Here is created by expo folder and i copy folders of existing react-native and dependencies as you can see in package.json

{
  "name": "empty-project-template",
  "main": "node_modules/expo/AppEntry.js",
  "private": true,
  "scripts": {
    "start": "expo start",
    "android": "expo start --android",
    "ios": "expo start --ios",
    "eject": "expo eject"
  },
  "dependencies": {
    "npm" : "^6.4.1",
    "expo": "^30.0.1",
    "react": "16.3.1",
    "react-native": "https://github.com/expo/react-native/archive/sdk-30.0.0.tar.gz",
    "react-native-onesignal": "^3.2.4",
    "react-native-wkwebview-reborn": "^1.21.0",
    "react-navigation": "^2.13.0"
  },
  "devDependencies": {
    "babel-jest": "22.4.3",
    "babel-preset-react-native": "4.0.0",
    "jest": "22.4.3",
    "react-test-renderer": "^16.4.1"
  },
  "jest": {
    "preset": "react-native"
  }
}

I’m starting the project through npm start and the result is those errors.

I’m guessing they did with simulators but i don’t have MacOS computer. I just have Windows 10 computer and im trying to open on my iphone with expo app. Which is the step am i skipping?
Thanks advance to for your answer.


#2

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.