Exp Build Issue : Bundle Identifier


#1

I am currently starting the build process as mentioned in the link below.

https://docs.expo.io/versions/latest/guides/building-standalone-apps.html

I have completed Steps 1 & 2 and just started Step 3.

I have started the exp as mentioned in Step 3

This is my terminal session

[exp] There is a new version of exp available (46.0.6).
You are currently using exp 46.0.5
Run `npm install -g exp` to get the latest version
[exp] Using project at /Users/kavitha/Desktop/embryo
[exp] Warning: 'react-native' peer depencency missing. Run `npm ls` in /Users/kavitha/Desktop/embryo to see full warning.
[exp] 
[exp] If there is an issue running your project, please run `npm install` in /Users/kavitha/Desktop/embryo and restart.
[exp] Starting React Native packager...
[exp] Scanning folders for symlinks in /Users/kavitha/Desktop/embryo/node_modules (10ms)
[exp] Loading dependency graph.
[exp] Running packager on port 19001.
[exp] Dependency graph loaded.
[exp] Tunnel connected.
[exp] Expo is ready.
[exp] You can scan this QR code:


[exp] Your URL is: exp://vp-bwh.vpy.embryo.exp.direct:80
[exp] Logs for your project will appear below. Press Ctrl+C to exit.
[exp] Warning: 'react-native' peer depencency missing. Run `npm ls` in /Users/kavitha/Desktop/embryo to see full warning.
[exp] 
[exp] If there is an issue running your project, please run `npm install` in /Users/kavitha/Desktop/embryo and restart.

Then I opened another terminal window and executed the command exp build:ios

Terminal session from that window shown below

192-168-1-12:embryo kavitha$ exp build:ios
[exp] There is a new version of exp available (46.0.6).
You are currently using exp 46.0.5
Run `npm install -g exp` to get the latest version
[exp] Your project must have a bundleIdentifier set in app.json. See https://docs.expo.io/versions/latest/guides/building-standalone-apps.html

As can be seen it is complaining that bundle identifier is not available in app.json but bundle identifier is indeed present and available in my app.json

My app.json is shown below

{
  "expo": {
    "name": "embryo",
    "description": "An empty new project",
    "slug": "embryo",
    "privacy": "public",
    "sdkVersion": "22.0.0",
    "ios": {
      "bundleIdentifier": "com.kvn.embryo"
    },
    "version": "1.0.0",
    "orientation": "portrait",
    "primaryColor": "#cccccc",
    "icon": "./assets/icon.png",
    "splash": {
      "image": "./assets/splash.png",
      "resizeMode": "contain",
      "backgroundColor": "#ffffff"
    },
    "packagerOpts": {
      "assetExts": ["ttf", "mp4"]
    },
    "ios": {
      "supportsTablet": true
    }
  }
}

Can someone tell me what to do now and how to resolve this issue ?


#2

I was able to resolve the issue.

In my app.json I merged both the “ios” into one then the build went through successfully