expo build:ios -e -c fails

#1

I recreated all new certs and p12 files specifically for this build and uploaded during the build. Build logs can be found here:

Specifically:

generating IPA...
[stderr] /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/fastlane_core/lib/fastlane_core/ui/interface.rb:163:in `build_failure!': 
[stderr] [09:42:30] 'ios:build-and-sign-ipa' errored after 16 s
[stderr] [!] Error packaging up the application (FastlaneCore::Interface::FastlaneBuildFailure)
[stderr] [09:42:30] Error: Process exited with non-zero code: 1
[stderr]     at ChildProcess.child.on (/usr/local/turtle-agent/tools-public/node_modules/@expo/spawn-async/build/spawnAsync.js:39:21)
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/fastlane_core/lib/fastlane_core/ui/ui.rb:17:in `method_missing'
[stderr]     at emitTwo (events.js:125:13)
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/error_handler.rb:112:in `handle_package_error'
[stderr]     at ChildProcess.emit (events.js:213:7)
[stderr]     at maybeClose (internal/child_process.js:927:16)
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/runner.rb:121:in `block in package_app'
[stderr]     at Socket.stream.socket.on (internal/child_process.js:348:11)
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/fastlane_core/lib/fastlane_core/command_executor.rb:93:in `execute'
[stderr]     at emitOne (events.js:115:13)
[stderr]     at Socket.emit (events.js:210:7)
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/runner.rb:117:in `package_app'
[stderr]     at Pipe._handle.close [as _onclose] (net.js:545:12)
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/runner.rb:27:in `run'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/manager.rb:19:in `work'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/commands_generator.rb:44:in `block (2 levels) in run'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/commander-fastlane-4.4.6/lib/commander/command.rb:178:in `call'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/commander-fastlane-4.4.6/lib/commander/command.rb:153:in `run'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/commander-fastlane-4.4.6/lib/commander/runner.rb:476:in `run_active_command'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/fastlane_core/lib/fastlane_core/ui/fastlane_runner.rb:75:in `run!'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/commander-fastlane-4.4.6/lib/commander/delegates.rb:15:in `run!'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/commands_generator.rb:75:in `run'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/gym/lib/gym/commands_generator.rb:15:in `start'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/fastlane/lib/fastlane/cli_tools_distributor.rb:100:in `take_off'
[stderr] 	from /usr/local/lib/ruby/gems/2.4.0/gems/fastlane-2.95.0/bin/fastlane:20:in `<top (required)>'
[stderr] 	from /usr/local/bin/fastlane:23:in `load'
[stderr] 	from /usr/local/bin/fastlane:23:in `<main>'
unable to build and sign IPA

The logs dont appear to give me any clue as to what is wrong. Only that it fails while generating the IPA and something about fastlane. I tried letting Expo handle the creation of all the certs but it always fails to create the provisioning profile even though I am an admin on the team.

Any help is appreciated! Thank you.

#2

Hi! Sorry about that – we’re always working to improve these logs and error messages but right now it looks like the real error isn’t making it through. In this case we’re seeing this:

exportArchive: No signing certificate "iOS Distribution" found
exportArchive: Provisioning profile "XXXXXXXXXXXX" is not an "iOS Ad Hoc" profile.

We don’t currently support building against an ad hoc profile right now, unfortunately. You can still compile a standalone app yourself and sign it as ad hoc using the instructions on our main repo, but our build service doesn’t currently support this.

closed #3

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.