EXPO CLI can't launch ios Simulator

Hi Guys, im new in expo. When i try to open iOS simulator in a just created app, i get this error:

Unexpected token I in JSON at position 0
SyntaxError: Unexpected token I in JSON at position 0
at JSON.parse ()
at _listSimulatorDevicesAsync (/@expo/xdl@56.4.1/src/Simulator.ts:221:21)
at processTicksAndRejections (internal/process/task_queues.js:93:5)
at _bootedSimulatorDeviceAsync (/@expo/xdl@56.4.1/src/Simulator.ts:241:29)
at _openAndBootSimulatorAsync (/@expo/xdl@56.4.1/src/Simulator.ts:142:24)
at Object.upgradeExpoAsync (/@expo/xdl@56.4.1/src/Simulator.ts:391:3)
at /expo-cli@3.4.1/src/commands/client/index.js:247:11
at Command. (/expo-cli@3.4.1/src/exp.ts:81:7)

same happens if i try to run expo ios, expo client:install:ios etc. i do have iOS emulator installed, and i also tried to have it open manually first. but no luck.

@nsigal What version of os x are you running?

I’m running into the same issues on one of my machines, but everything works as expected on the others. The only difference is that the machine it’s failing on is using the catalina preview/beta.

hi! thanks for replying. it’s mojave 10.14.6

Well, there goes that theory! I’ll update here if I find anything over the next few days.

i’ve updated to xcode 11.1 and it’s working now!

Thanks a million @nsigal—for anyone else who may have stumbled onto this thread and is having issues with xcode failing to install additional components:

If you’re seeing "The package “MobileDevice.pkg” is untrusted." in the logs/console, you can temporarily set your machine’s date to Oct. 1st 2019 and retry the install.

1 Like