Expo cli install error

Getting this error after running npm install -g expo-cli

npm ERR! code EPERM
npm ERR! syscall unlink
npm ERR! path C:\Users\haseeb\AppData\Roaming\npm\node_modules\expo-cli\node_mod
ules@expo.xdl.DELETE\binaries\windows\adb\AdbWinApi.dll
npm ERR! errno -4048
npm ERR! Error: EPERM: operation not permitted, unlink ‘C:\Users\haseeb\AppData
Roaming\npm\node_modules\expo-cli\node_modules@expo.xdl.DELETE\binaries\window
s\adb\AdbWinApi.dll’
npm ERR! [OperationalError: EPERM: operation not permitted, unlink ‘C:\Users\ha
seeb\AppData\Roaming\npm\node_modules\expo-cli\node_modules@expo.xdl.DELETE\bi
naries\windows\adb\AdbWinApi.dll’] {
npm ERR! cause: [Error: EPERM: operation not permitted, unlink ‘C:\Users\hasee
b\AppData\Roaming\npm\node_modules\expo-cli\node_modules@expo.xdl.DELETE\binar
ies\windows\adb\AdbWinApi.dll’] {
npm ERR! errno: -4048,
npm ERR! code: ‘EPERM’,
npm ERR! syscall: ‘unlink’,
npm ERR! path: ‘C:\Users\haseeb\AppData\Roaming\npm\node_modules\expo
-cli\node_modules\@expo\.xdl.DELETE\binaries\windows\adb\AdbWinApi.dll’
npm ERR! },
npm ERR! stack: “Error: EPERM: operation not permitted, unlink ‘C:\Users\has
eeb\AppData\Roaming\npm\node_modules\expo-cli\node_modules\@expo\.xdl.DE
LETE\binaries\windows\adb\AdbWinApi.dll’”,
npm ERR! errno: -4048,
npm ERR! code: ‘EPERM’,
npm ERR! syscall: ‘unlink’,
npm ERR! path: ‘C:\Users\haseeb\AppData\Roaming\npm\node_modules\expo-c
li\node_modules\@expo\.xdl.DELETE\binaries\windows\adb\AdbWinApi.dll’,
npm ERR! parent: ‘expo-cli’
npm ERR! }
npm ERR!
npm ERR! The operation was rejected by your operating system.
npm ERR! It’s possible that the file was already in use (by a text editor or ant
ivirus),
npm ERR! or that you lack permissions to access it.
npm ERR!
npm ERR! If you believe this might be a permissions issue, please double-check t
he
npm ERR! permissions of the file and its containing directories, or try running
npm ERR! the command again as root/Administrator.

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\haseeb\AppData\Roaming\npm-cache_logs\2020-03-07T17_45_24

Did you find a solution? I’m having this exact problem. Please share if so

Perhaps this will help:

I got the same “AdbWinApi.dll” error, and found a Adb process running via Task Manager, which I killed. The install got past that but choked on a “rename C:…\expo-cli -> C:…expo-cli.DELETE”. Rebooted machine alleviated that issue; install completed.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.