Expo client sdk 34, app stuck at "Building JavaScript bundle... 100%"

I have the latest version of expo-cli installed, I have followed the steps to update sdk 34 and no error appears, but the application does not pass “Building JavaScript bundle … 100%”

Does this happen on a new expo init project?

No, it is a project that comes from version 28, 30, 31, 32, 33 of the sdk … All the updates were good at the time, although some cost their effort.
The problem appears in the emulator and in the physical device.

The biggest change was in import syntax, so I would double check that all your import statements have been updated. Any places where you’re still using the old method should result in an error though, so I’m not sure why you’re stuck at building the js bundle…

Can you run commands like expo publish? (careful as this will send out an update to any live apps on the release channel you publish to)

All imports were changed when I updated to sdk 33, now half an error that had version 5 instead of 6 of expo-camera, linear-gradient, image-manipultator … But I solved it with expo install.
The truth is that I do not understand why it is frozen in “Building JavaScript bundle … 100%”
Why do you want me to use the expo publish command, for now I don’t want to publish my project?
Thanks for your reply

Why do you want me to use the expo publish command, for now I don’t want to publish my project?

You could use release channels to prevent an update going out to your project, but on second thought there’s no real need to test expo publish

Can you try running it in production mode? expo start --no-dev --minify

Your app is probably getting stuck in a loop somewhere. Best move going forward is to strip your app down and try to isolate where the source of the problem is

I think that if the reason were an Infinity looop, with sdk 33 I would have the same problem and I don’t

I have the same issue, even with a new project… (expo init)
My projet worked well 1 week ago, but not anymore

I don’t know how I can fix it, my application is already big. For now I am still working with sdk 33 because they enabled Android 64 bit construction. I hope I can fix this soon!

Any solution for the problem? @charliecruzan, @spoutnik97

what version of expo-cli are you using? Can you share a project with me that allows me to reproduce this?

expo-cli 3.0.8
node v10.16.0
npm 6.9.0
ubuntu 16.04
I don’t think I can reproduce a project with this problem. My project is big and I am developing for a company. It works perfect in sdk 33.

@spoutnik97 says even a new project created with expo init has the same problem. @jorgem, does a new project also have the same problem for you?

I just created an init project, with navigation and it worked perfectly.
I do not know, it may be some dependency, although as I mentioned earlier in sdk 33 it works and if there have not been some very deep changes from sdk 33 to sdk 34 I am surprised that it does not work.
Thank you!

I should note that there have been some breaking changes with SDK 34, namely with import syntax. If you aren’t using new modularized imports (and installing packages with expo install) you’ll get an error. You can read all about it here

@charliecruzan When I refer to very deep changes it is because in an expo document I read that sdk 33 is the one that would have many more changes than sdk 34. I made the transition from sdk 32 to 33 following all the steps and removing all the warnings in sdk 33 , and in sdk 34 I have done the same but since I already had the imports I had to update the modules from 5.0 to 6.0 with expo install (this I put in my fifth comment of this post) and I do not get any error after following https: //blog.expo.io/expo-sdk-34-is-now-available-4f7825239319.