expo eject => Unable to install expokit@1.7.1.

#1

I’m trying to run expo eject for a expo 30.0.0 project but it fails to install expokit.

Validating project manifest...
Skipping iOS because you are not running macOS.
Writing ExpoKit configuration...
Installing 'expokit' package...
Unable to install expokit@1.7.1.
Please install manually to complete detaching.
Finished detaching your project! Look in the `android` and `ios` directories for the respective native projects. Follow the ExpoKit guide at https://docs.expo.io/versions/latest/guides/expokit.html to get your project running.
[23:22:13] Ejected successfully!

I also tried installing it manually using npm install expokit@1.7.1 but I still get the error when I run exp detach.

Any suggestions?

0 Likes

"exp publish" breaks my detached app. Assets and Vector Icons not displayed anymore.
#2

Hey @dfels,

What version of the CLI are you running? Pinging internally about this as well.

Cheers,

Adam

0 Likes

#3

This error message means the command npm install --save expokit@1.7.1 failed for some reason. As a workaround you can just run npm install --save expokit@1.7.1 after the eject command has finished with this error. You don’t have to run eject/detach again after that, because installing the expokit package is the final step of ejecting.

0 Likes

#4

@adamjnav I am running version 2.2.4

@fson I installed it using npm install --save expokit@1.7.1 and got this as result:

npm WARN optional Skipping failed optional dependency /sane/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.2.4
npm WARN enoent ENOENT: no such file or directory, open '/home/dfels/react_native_projects/project/node_modules/fsevents/package.json'
npm WARN eslint-plugin-react-native@3.5.0 requires a peer of eslint@^3.17.0 || ^4 || ^5 but none was installed.
npm WARN expo-camera@1.1.0 requires a peer of react@^16.4.0 but none was installed.
npm WARN expo-gl@1.0.2 requires a peer of react@^16.4.0 but none was installed.
npm WARN react-native-maps@0.21.0 requires a peer of react-native@^0.51 || ^0.52 || ^0.53 || ^0.54 but none was installed.
npm WARN react-native-reanimated@1.0.0-alpha.6 requires a peer of react@16.0.0-alpha.6 but none was installed.
npm WARN react-native-reanimated@1.0.0-alpha.6 requires a peer of react-native@^0.44.1 but none was installed.

Out of curiosity I tried to run expo eject again and I’m still getting the Unable to install expokit@1.7.1. error.
So do you think the eject was successful and I can start working on the project now?

Thank you guys.

0 Likes

#5

Those warnings can be ignored.

The “Unable to install expokit” error means the eject was successful otherwise, but just installing that package with npm failed. You can run npm install --save expokit@1.7.1 and then start working on the project.

0 Likes

#6

Are you tried with yarn? Expo team love yarn.

0 Likes

closed #7

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

0 Likes