Expo Firebase App: cannot find symbol FirebaseAppPackage


#1

Hi!
I’m testing the expo-firebase-app module (thank you so much for this!), but after following instructions from https://www.npmjs.com/package/expo-firebase-app (and the blog post)when I try to build the android app using ./gradlew installDevMinSdkDevKernelDebug I get the following error

      new FirebaseAppPackage() // Include this. 
          ^
  symbol:   class FirebaseAppPackage
  location: class MainActivity
1 error

I’m using a clean/just created/ejected expo app. Is there something else I need to do?


#2

I’m not sure exactly what’s wrong. You could refer to the boilerplate. Here is what that would look like:


#3

This was the line I was missing (maybe it was obvious for someone with Java/Android experience, but not for a JS guy :sweat_smile:).

Thanks so much for making our life easier :heart:


#4

Right, in Android Studio this will be automatically imported. This is probably why I didn’t add as much emphasize to it :sweat:Glad you figured it out though! :grin::blue_heart:


#5

JS guys are afraid only by thinking in opening Android Studio :joy:that’s why we love Expo so much. Thanks and have a fun weekend!


closed #6

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.