Expo is driving me crazy - could not load exp://host:port

#1

I just uninstalled my Expo Client App on Android Device (I installed it through the play store), and installed it again with the [expo install:android] command. After the installation, all the projects that am able to run before were no longer running. The Expo Client is showing error as shown below

I have tried all possible solutions but nothing worked. The reason I uninstalled and install again is whenever I try running any project created with Expo SDK 28 upwards, the Expo Client will throw error “The Expo SDK is required to run this project”. Then I saw a fix on this forum to uninstall the Expo Client and re-install with the expo cli. Nothing is working anymore cause the new client is not even loading any app. How can I fix this?

1 Like
#2

Hey @emmanuel_2u,

Sorry you are having such frustrating experiences getting this running so you can start developing. Any chance this could be a network issue? Have you tried on a different network? Also, what version of the expo-cli are you running?

Cheers,

Adam

#3

@adamjnav

  1. Network issue? Don’t think so
  2. Have I try running on different network? Do you mean choosing the tunnel or local option as listed here

tunnellocal

If so, yes I have tried for the local but not the tunnel and it’s still not working.
3. expo-cli version is 2.1.3

#4

Hey @emmanuel_2u,

Sorry for the delayed follow up. By different network, I mean like a home network and a work network. Sometimes work (or personal) networks have firewalls or proxies that cause issues loading Expo projects locally.

Cheers,

Adam

#5

It’s finally working if I connect using tunnel. Thanks!

1 Like
closed #6

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.