Expo project crash on android simulator & works fine on IOS simulator

Hi, i have an Expo project (SDK 40) that works fine on IOS simulator ( Iphone, Ipad ) with different IOS versions no problem, but when it comes to android simulator it crashes right after the splash screen, when build the apk file and trying it on a physical android device it works with no problems, the only issue is with the android simulator, any ideas?

Expo diagnostics :

Expo CLI 4.2.1 environment info:
System:
OS: Windows 10 10.0.18362
Binaries:
Node: 12.18.3 - C:\Program Files\nodejs\node.EXE
npm: 6.14.6 - C:\Program Files\nodejs\npm.CMD
IDEs:
Android Studio: Version 4.0.0.0 AI-193.6911.18.40.6626763
npmPackages:
expo: ^40.0.0 => 40.0.1
react: 16.13.1 => 16.13.1
react-dom: 16.13.1 => 16.13.1
react-native: https://github.com/expo/react-native/archive/sdk-40.0.1.tar.gz => 0.63.2
react-native-web: ~0.13.12 => 0.13.18
Expo Workflow: managed

For anyone with this problem i just discovered the issue, all i had to do is to remove the “image” from the splash configuration on the file app.json which means for some reason the emulator doesn’t accept that image and i have to change it, disabling it allowed the emulator to run the project again with no issues

Hi @bader1995

I’m glad you were able to solve this!

Did you get any error messages when running it on the android emulator?

No, everything worked perfectly no error messages at all, the issue was that the splash screen image i used was a very big one with the size over 3420px and the emulator had problems rendering it, i used it in the first place to keep the quality at the best in higher resolution phones since i couldn’t use svg one there (the splash screen only support png), i reduced the image size to 1242 x 2688 and it worked with no issues.

1 Like