Expo standalone build screen gets cut off (statusbar height) at the bottom


#1

Weird thing seems to happen on standalone builds of my app. We’re using nativebase with Expo and it works perfectly in the Expo app but once we build a standalone version of the app the screen gets cut off at the bottom. I’ve figured that it’s the statusbar height but adding any margin or padding doesn’t help, has anyone else ran into this issue and have any information on how to fix it?

I’ve found one similar issue: https://github.com/expo/expo/issues/2078

Here’s what it looks like on standalone (note that the gap doesn’t appear in the Expo app):


#2

Hi wixel,

I’m having the same issue with my standalone app. Were you able to fix this?

Thanks!
-Ken


#3

Haven’t found a fix yet, but will keep this post updated with anything I find. :slightly_smiling_face:


#4

Also posted the same thing. Hope we find a fix soon.


#5

Hey @weeken88 and @wixel,

I reported this internally. I circle back in this thread since you both are in it already rather than reporting in your other thread @weeken88. Hopefully we can get it fixed soon. Sorry for the trouble.

Cheers,

Adam


#6

Thanks Adam!


#7

Hi Guys,

I was able find a fix/workaround. Here’s what I did:

Hope this works with you too!
-Ken


#8

Awesome, will check if this works on our app, one thing to note, is we’ve added ‘androidStatusBar’ to app.json for the keyboard behaviour on inputs, going to try your suggestion @weeken88 and report back on this thread.


#9

If my workaround doesn’t work. Try checking back on the github post you mentioned, the TS replied with his workaround. Hope you fix it soon!

-Ken


#10

Ah yeah as I expected, this workaround fixes the issue but then when focusing on an input the keyboard will overlap the input, this is why I initially used ‘androidStatusBar’. @adamjnav you might find these findings useful.

Glad you got it sorted on your side @weeken88, thanks for all the input. I’ll see if I can figure out another way to avoid keyboard and keep the statusbar working correctly.


#11

Try using KeyboardAvoidingView instead of View. This worked for me.


Expo Build (standalone apk) shifts view a few pixels up
#12

Did you find a solution for the keyboard avoiding view on Android ? I’m having this issue and I don’t want to detach :frowning:
It’s sad that an old issue like that hasnt been fixed yet


closed #13

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.