expo upload:ios throws "Could not find transporter" after Xcode upgrade

I am getting the following errors when executing “expo upload:ios”.

[22:08:28]: Going to upload updated app to App Store Connect
[22:08:28]: This might take a few minutes. Please don't interrupt the script.
Failed to upload the standalone app to the app store.
Could not find transporter at /Applications/Xcode.app/Contents/Developer/. Please make sure you set the correct path to your Xcode installation.
Set EXPO_DEBUG=true in your env to view the stack trace.

Here is my diagnostics output…

  Expo CLI 3.1.0 environment info:
    System:
      OS: macOS 10.14.6
      Shell: 3.2.57 - /bin/bash
    Binaries:
      Node: 8.12.0 - /usr/local/bin/node
      npm: 6.9.0 - /usr/local/bin/npm
    IDEs:
      Android Studio: 3.4 AI-183.6156.11.34.5522156
      Xcode: 11.0/11A420a - /usr/bin/xcodebuild
    npmPackages:
      expo: ^34.0.3 => 34.0.4 
      react: 16.8.3 => 16.8.3 
      react-native: https://github.com/expo/react-native/archive/sdk-34.0.0.tar.gz => 0.59.8 
      react-navigation: ^3.11.0 => 3.11.0 
    npmGlobalPackages:
      expo-cli: 3.1.0

The issue started after I was forced to upgrade Xcode today.

Many thanks in advance!

Jan

2 Likes

I have the same issue, I think it’s because Application Loader was removed from Xcode 11. It seems like there’s no way to upload an app to the app store currently?

same here.

Same here. I also get this error when I try to upload my ipa via an old ApplicationLoader (with XCode 9.1)

ERROR ITMS-90596: "Invalid Bundle. The asset catalog at 'Payload/ExpoKitApp.app/Assets.car' can't be processed. Rebuild your app, and all included extensions and frameworks, with the latest GM version of Xcode and resubmit."

@cobbers that error looks like a separate issue. I was able to use Application Loader after downgrading to Xcode 10.3.

2 Likes

@seveneightn9ne Thats good to hear. Im busy downloading 10.3 now

Same, when Xcode updated to 11, I had Application Loader open, and it disappeared. Is the only fix right now to download an older version of Xcode? That seems crazy.

Even using exp upload:ios doesn’t work for me right now.

There’s an issue for this:

You were right @seveneightn9ne. The AppLoader with Xcode 10.3 gave me a better error message. I am trying to add branch.io and I messed up the associatedDomains format.
Now I’m fighting with provisioning profiles which is always a pain in the proverbial

From Apple: “Starting with Xcode 11 , Application Loader is no longer included in Xcode.”

I was able to get it to work by manually downloading Application Loader, but it required several steps.

https://forums.developer.apple.com/thread/64041

@nickhough I didn’t see anything in this thread that looked up to date. Which steps did you follow specifically?

I manually installed Application Loader.

https://itunesconnect.apple.com/apploader/ApplicationLoader_3.1.dmg

image

Then I manually installed Transporter.

https://help.apple.com/itc/transporteruserguide/#/apdA3ae5a8b0?sub=apdA687d545d

I think the version of Application Loader I ended up with is old, but it appears to be working. I should note, I’m actually using Application Loader to do my uploads, not expo upload:ios, so results may very.

2 Likes

Thank you Nick! I am able to upload my ipa following your instruction. Now processing…

Lin

This workaround works for me: https://github.com/expo/expo-cli/issues/927#issuecomment-533832803

2 Likes

Glad you were able to get it working again!

Thanks siddemo, it works so good for mac. There are just two steps practically in command
xcrun altool --upload-app -f pathtothefile.ipa -u youremail@apple.com
after that the password generated by appleId. It can generated in https://appleid.apple.com/account/manage, security section.

Looks like this has been fixed:

fson commented 26 minutes ago

This should be fixed in the latest version of expo-cli . However, please open an issue if you’re still experiencing problems with Xcode 11 and the expo build:ios or expo upload:ios commands!

Application Loader is no longer exist with xcode 11.0+ use “Transporter” instead.