Expokit unfortunatly app has stoped

#1

I’m struggling to eject and build a project for 2 weeks now! after a lot of searching and reinstalling everything even windows, finally yesterday, I have managed to update my project from SDK 28 to 29 and build worked! But, now whenever I run the app on my real device unfortunately app has stopped error appears and whenever I build on a virtual device nothing happen only a white screen, so I created many new projects either with CRNA, exp or expo-cli command line and ejected them and same error unfortunately app has stopped appears again …

I don’t know why there are 2 ways to build a project one with the run.sh and the one documentation suggested. the one with run.sh try to run expo app even so it’s a native Android app it doesn’t require that!

I think expo documentation lacks a lot of integrity I don’t want to wait 2 more weeks to solve this :frowning:
any help will be appreciated

#2

Hey @eagolism,

Sorry you’ve been dealing with all of this. Just for clarification:

Are you saying that freshly created project with no code changes results in the unfortunately the app has stopped error after being ejected or detached?

Also, with your original project, have you tried looking in your device logs for any crashes that may be occurring? I see you mention Android once, is this occurring on iOS as well?

Cheers,

Adam

2 Likes
#3

thank you for answering me @adamjnav

Are you saying that freshly created project with no code changes results in the unfortunately the app has stopped error after being ejected or detached?

yes

I see you mention Android once, is this occurring on iOS as well?

i haven’t yet, is there a windows virtual device for IOS?

Also, with your original project, have you tried looking in your device logs for any crashes that may be occurring?

adb logcat:


08-07 19:45:59.010  8142  8142 E AndroidRuntime: FATAL EXCEPTION: main
08-07 19:45:59.010  8142  8142 E AndroidRuntime: Process: com.roll.pi, PID: 8142
08-07 19:45:59.010  8142  8142 E AndroidRuntime: java.lang.RuntimeException: Unable to start activity ComponentInfo{com.roll.pi/host.exp.exponent.MainActivity}: java.lang.NullPointerException: Attempt to invoke virtual method 'boolean java.lang.String.equals(java.lang.Object)' on a null object reference
08-07 19:45:59.010  8142  8142 E AndroidRuntime:        at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2447)
08-07 19:45:59.010  8142  8142 E AndroidRuntime:        at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2511)
08-07 19:45:59.010  8142  8142 E AndroidRuntime:        at android.app.ActivityThread.-wrap11(ActivityThread.java)
08-07 19:45:59.010  8142  8142 E AndroidRuntime:        at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1360)
08-07 19:45:59.010  8142  8142 E AndroidRuntime:        at android.os.Handler.dispatchMessage(Handler.java:102)
08-07 19:45:59.010  8142  8142 E AndroidRuntime:        at android.os.Looper.loop(Looper.java:148)
08-07 19:45:59.010  8142  8142 E AndroidRuntime:        at android.app.ActivityThread.main(ActivityThread.java:5480)
08-07 19:45:59.010  8142  8142 E AndroidRuntime:        at java.lang.reflect.Method.invoke(Native Method)
08-07 19:45:59.010  8142  8142 E AndroidRuntime:        at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:726)
08-07 19:45:59.010  8142  8142 E AndroidRuntime:        at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:616)
08-07 19:45:59.010  8142  8142 E AndroidRuntime: Caused by: java.lang.NullPointerException: Attempt to invoke virtual method 'boolean java.lang.String.equals(java.lang.Object)' on a null object reference
08-07 19:45:59.010  8142  8142 E AndroidRuntime:        at host.exp.exponent.ExponentManifest.fetchCachedManifest(ExponentManifest.java:292)
08-07 19:45:59.010  8142  8142 E AndroidRuntime:        at host.exp.exponent.AppLoader.start(AppLoader.java:91)
08-07 19:45:59.010  8142  8142 E AndroidRuntime:        at host.exp.exponent.experience.DetachActivity.onCreate(DetachActivity.java:95)
08-07 19:45:59.010  8142  8142 E AndroidRuntime:        at android.app.Activity.performCreate(Activity.java:6308)
08-07 19:45:59.010  8142  8142 E AndroidRuntime:        at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1107)
08-07 19:45:59.010  8142  8142 E AndroidRuntime:        at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2400)
08-07 19:45:59.010  8142  8142 E AndroidRuntime:        ... 9 more
08-07 19:45:59.020   712  1613 D ActivityManager: Prepare to send crash information Messege to SystemGaService
08-07 19:45:59.032   313   342 I KERNEL  : [94931.136350] [DISP] brightness level = 15
08-07 19:45:59.020  8142  8186 W Settings: Setting airplane_mode_on has moved from android.provider.Settings.System to android.provider.Settings.Global, returning read-only value.
08-07 19:45:59.020  8142  8186 E AppLoader: Could not load app: java.net.UnknownHostException: Unable to resolve host "index.exp": No address associated with hostname
08-07 19:45:59.020  8142  8186 W Settings: Setting airplane_mode_on has moved from android.provider.Settings.System to android.provider.Settings.Global, returning read-only value.
08-07 19:45:59.040   267   267 D hwcomposer: void android::intel::DisplayAnalyzer::handleIdleExitEvent(): handling idle exit event
08-07 19:45:59.040   712   834 I OpenGLRenderer: Initialized EGL, version 1.4
#4

which version of Gradle is being used to build the sdk app version 29?
the build I did yesterday downloaded gradle-4.4-all!!
is this version supported?

#6

Hi @eagolism - sorry you’re having trouble with this :anguished: have you run exp publish at least once since upgrading to SDK 29?

closed #7

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.