Failed upgrading expokit sdk 25 on android


#1

Hi. Today, I am trying to upgarde expokit from 24 to 25 and having trouble. It as before, works like charm in ios but android is failing me again.

I’ve done package upgrade as guide from here.

Then I followed guide here and replaced .expo/android with 25 version. I’ve done ios successfully but android studio can’t find ‘host.exp.exponent:expoview:25.0.0@aar’.

I felt like from expo version 24, the android code is not referencing viewUrl in .expo/android. However, I am not sure. This was just my feeling. I want expo team to checkout what I should do from here.

Thank you.


#2

hi there,

Here’s one round about way to get that aar.

  1. Make a fresh project with exp, have it be SDK 25
  2. exp detach
  3. From root of the project, the aar you want is here: ./maven/host/exp/exponent/expoview/25.0.0/expoview-25.0.0.aar
  4. Copy to your project?

Just a possible way to go about this problem…


#3

@edgar
Yes. I’ve solved it this way also. But I think this process should be updated in expo docs also.


#4

Hi,
I’m having the same issue!
But I cannot solve it…
I followed the instruction above, I added the expoview-25.0.0.aar inside the lib folder, but still I have the same problem.
After include the lib the error is:

Error:(12, 25) error: cannot find symbol class ExponentActivity

in the MainActivity.java.

Can you please help me to fix this problem? I’m blocked now.


#5

@lucapau
I think this would be good if you post this one to issue in github.

I’ve cleanly created new project to solve this issue. Upgrade is really bad from sdk 24. Need more clear docs. Expo team doesn’t seem to try upgrade from expokit before actually publishing new version. Hope they are aware of this issue.


#6

@lucapau @dooboolab I’ve hit up against this same issue when trying to update to SDK25 in Android.

Have you guys figured anything out?

I created a github issue here: https://github.com/expo/expo/issues/1379


#7

@nickyhajal I just detached a new app and replaced all android and ios folders in my project…
Something is missing in the upgrade documentation.


#8

@lucapau
He is right. I am also doing it that way. Upgrade document is currently old. Expo should update the doc. For now only way is to re-download the newly detached android source.


closed #9

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.


Define exactly what does and does not work with ExpoKit