Fetch fails on IOS in Expo 26

#1

I upgraded my app to Expo 26 but now I am running into errors on IOS when using fetch. The same code works fine in Expo 25. I believe this is due to this probem: https://github.com/facebook/react-native/pull/18547. Can this PR be included with https://github.com/expo/react-native/archive/sdk-26.0.0.tar.gz?

1 Like
#2

For now you can work around it by changing your ‘HEAD’ requests to ‘GET’. Note that the PR you linked to involves changes in the iOS Objective-C code, not in the JavaScript code, so including its changes in the npm package (…/sdk-26.0.0.targ.gz) will not help. It will eventually be released as part of a new Expo native release, at which point you won’t need the workaround.

1 Like
#3

This is happening for me on a POST so I can’t change it to a GET

#4

We’re planning on including the fix for this in the next minor release

1 Like
#5

I’m seeing the crash also on a GET or POST where a 204 No Content is returned. Since i’m not able to change the API, Is there an ETA on the minor release? thanks!

4 Likes
#6

I’m also experiencing this issue. If you’re able to fix this with the next minor release would be great. Thanks!

#7

Hi - the minor release went out earlier this week, so please update to iOS client version 2.4.7 from the app store. SDK 26 in that build does include the PR linked in the original post.

#8

hi, is there an update for expokit? the ios expoview still points to 2.4.4 in https://expo.io/--/api/v2/versions

1 Like
#9

when can we expect the expokit SDK to be updated to 2.4.7? or are there any manual steps to update to this latest version?

#10

Any update on this? We’re really stuck until we can have 2.4.7 on ExpoKit

closed #11

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.