Firebase Install Error

#1

Any one have this issue? how to fix this error?

Unable to resolve module firebase from E:\workspace\reactnative\auth-app-expo\src\Main.js: Module does not exist in the module map or in these directories: E:\workspace\reactnative\auth-app-expo\node_modules

This might be related to https://github.com/facebook/react-native/issues/4968 To resolve try the following: 1. Clear watchman watches: watchman watch-del-all. 2. Delete the node_modules folder: rm -rf node_modules && npm install. 3. Reset packager cache: rm -fr $TMPDIR/react-* or npm start – --reset-cache.

ABI18_0_0RCTFatal ABI18_0_0RCTSetFatalHandler ABI18_0_0RCTSetFatalHandler CFRunLoopRunSpecific CFRunLoopRunInMode GSEventRunModal UIApplicationMain Exponent

#2

Have you installed the firebase package? Check for sure that it exists on disk. You might also want to try restarting the packager, which I recommend doing after installing npm packages.

There are also some tips on how to reset the packager, which sometimes helps with this error about not finding modules: How to clear the React Native packager

#3

HI ide, in this case I am not be able to install firebase which thrown that error. I will try to follow your link for solution but I am using windows which I don’t get it how to do steps of 5, 6, 7, 8 :slight_smile:

  1. Run watchman watch-del-all to clear Watchman’s state
  2. Kill the watchman daemon process
  3. Delete the packager’s cache directory with rm -fr $TMPDIR/react-*
  4. Start XDE or exp
    With exp, run exp r -c for good measure