Getting this error error: unknown option `--release-channel'

#1

Hey,

I’m ready to release to the AppStore so built out tooling to handle release channels and was pretty excited until I got this error

error: unknown option `--release-channel'

I get that after running this command

 exp publish --release-channel development

changing development to production doesn’t seem to make a difference at all. I’ve looked searched and found that the general answer was the SDK version is not matching react-native however both my SDK and react-native versions are correctly upgraded to version 27 as the Expo’s blog upgrade guide. In fact, I upgraded to 27 because this issue was happening on version 26.

Does anyone know what could cause this error?

I’ve tried the following

  • upgrading to expo 27
  • removing node_modules and re-installing
  • clearing npm cache, removing node_modules and re-installing
  • changing node versions with nvm to different versions of node. Currently running v8.9.4

Thanks!

0 Likes

#2

Ok, so I just solved this so I’ll post what fixed the problem.

There is a big difference between the globally installed exp package and the expo package in your package.json

You still must do a npm install -g exp in order to get the exp package

Hope this helps someone in the future.

1 Like

closed #3

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

0 Likes